Last updated: 11-Feb-2003
Command Feature
default route: usually route into the network cloud
static route: usually route toward the hub
static routes are classless
Stop advertising network To suppress networks from being advertised in updates
router rip
network 172.16.0.0
distribute-list 1 out serial 1 Only 1 in list and only 1 out list per routing protocol or per routing/interface
access-list 1 deny 172.16.8.0 0.0.0.255 Stop the network 172.16.8.0 from being advertised by RIP, out of s1 only
access-list 1 permit any
Control which network is redistributed & advertised
router rip
network 172.16.0.0
redistribute ospf 10 metric 4
distribute-list 1 out ospf 10 Do not allow advertising of routes coming from OPSF 10
out: out from OSPF 10
access-list 1 deny 192.168.8.0 0.0.0.255 Stop the network 192.168.8.0 from being redistributed from OPSF to RIP
access-list 1 permit any
To filter networks received in updates Only works properly with distance-vector protocols
router rip
network 172.16.0.0
distribute-list 1 in serial1 Deny 192.168.8.0 if it arrive from Serial1
Won't be processed by RIP
access-list 1 deny 192.168.8.0 0.0.0.255 Stop the network 192.168.8.0 from being redistributed from OPSF to RIP
access-list 1 permit any
Split horizon
Split-horizon is a layer 2 behavior, knows nothing of layer 3
no ip split-horizon Disable split-horizon on multipoint interface when hub & spoke and classful [RIP...], if spokes need to talk to each other/receive routing updated from each others
Only affect RIP for not EIGRP, need: NO IP SPLIT-HORIZON EIGRP X
Must be disabled on interfaces with secondary addresses or secondary address will not be advertised
EIGRP does not use split-horizon when advertising routes learned through redistribution This not affected by ip split-horizon eigrp
Split-horizon is DISABLED by default for RIP/IGRP on physical interfaces and point-to-multipoint subinterfaces.
Split-horizon is always ENABLED on point-to-point subinterfaces.
Split-horizon is NEVER DISABLED by default for EIGRP on any type of Frame Relay interface. Must be explicitly disabled with "no ip split-horizon eigrp ".INTERFACES & MULTIPOINTS & CLASSFUL PROTOCOL NO IP SPLIT-HORIZONEIGRP at the interface: no ip split-horizon eigrp 2001As soon as the subinterface is configured, split horizon is automatically disabled. This is the default behavior.Only for distance vector protocols [RIP/EIGRP/IGRP]interface Serial0/1 This is the hubip address 192.1.1.2 255.255.255.0encapsulation frame-relayno ip split-horizon eigrp 10 So that both spokes can see each other, only affect eigrp 10 nothing elseframe-relay map ip 192.1.1.1 100 broadcast so that the routing goes throughframe-relay map ip 192.1.1.3 200 broadcastNotesRouter should not install a summarized major network route from a major network from which it has a subnetRouting loopsMost routing loops occur on distance vector in regards to redistribution and/or Admin Dist issues..Rip/Igrp - show ip route to look for "possibly down" message would indicate a routing loopFor inside to outside, routing should always take place before NAT.BGP - Show ip bgp to watch if the bgp table # increments would indicate loopshow ip traffic to spot incrementing "bad hop counts" would indicate loops.Finally, once you isolate the loop, use the trace command to follow the routing path and through elimination find the source of the loop.Increases routing metric ==indicates routing loopClassful protocols: make all other interfaces as passive, including BRIsDebug and monitorlogging buffered 16384show logg will show the results of the debugsshow ip protocol will show the details of each protocolsdebug ip routing show the routing table activitiesdebug ip icmpping 172.16.4.255 Will ping all hosts on subnetencapsulation failed & frame-relay debug frame packetencapsulation failed & ISDN debug dialer packetdebug ISDN q931debug ppp encapsulationencapsulation failed & ATM debug atm packetencapsulation failed & ethernet debug arpencapsulation failed & token-ring debug arpno ip route-cachedebug ip packet will show all the packetsdebug ip packet detail 101 access-list 101 permit icmp any anydebug ip ripdebug ip ospf adjdebug ip eigrpDistances and route controlsModify distance when trying to manipulate the choice of one protocol over another.If multiple routes within a protocol, use metric to modify the path.router eigrp 109network 192.31.7.0network 128.88.0.0passive-interface serial 1/1 Always put the non-routing interfaces as passivepassive-interface serial 1/1.1 Also place the sub-interfaces as passive + the full interfacepassive-interface BRI0distance 255 Sets the default administrative distance to 255, which instructs the Cisco IOS software to ignore all routing updates from routers for which an explicit distance has not been set.distance 90 192.31.7.0 0.0.0.255 Sets administrative distance for all routers on the network 192.31.7.0 to 90distance 120 128.88.1.3 0.0.0.0 Sets administrative distance for the router with the address 128.88.1.3 to 120.distance 75 0.0.0.0 255.255.255.255 Set the distance of all routes under eigrp 109 to 75metric weights 0 K1 k2 k3 k4 k5 0 is type of service, then the K values All within AS must have same Ksinterface s0ip address 172.10.10.10 255.255.255.0bandwidth 64 Changing the bandwidth will also affect OSPFdelay 20000 Value from show interface s0, preferred way of changing metrics for load sharing. Does not affect the real delay on the interfaceTo prefer a path v. another, add delay on the other pathDefault networks Make sure: ip classlessip default-network 179.10.0.0 RIP/IGRP/EIGRP: must be known to IGRP/EIGRP to be propagatedMust be classfuldefault-information originate If the ASBR already has the default route in its routing table [OSP/RIP]default-information originate always If the ASBR doesn't have a default route [OSPF only]ip route 0.0.0.0 0.0.0.0 x.x.x.x RIP & static default routeip default-gateway ONLY when ip routing is DISABLEDsee default section in each routing protocolMiscWhen "ip eigrp summary" is configured the summarized routes will not be advertised in EIGRP updates out that interfacepolicy Route-map to replace static routeinterface s1ip address 172.16.10.10 255.255.255.0ip policy route-map rm-static equivalent to: ip route 172.16.117.0/24 e0access-list 1 permit 172.16.117.0 255.255.255.0route-map rm-static permit 10match ip address 1set interface e0Debug/infoshow ip policyshow route-mapChanging metric on specific routes Use offset-list when redundant equal cost path an