分享
 
 
 

CCIELAB题目之CCBootcamplab1

王朝other·作者佚名  2008-05-19
窄屏简体版  字體: |||超大  

My Answer to CCBootcamp lab 1

Keywords: CCBootcamp answer ip local policy route-map OSPF NBMA

I had finished the CCBootcamp Lab 1 myself and find out that my answer is better then that one which is passing online. looking at that answer you will be wondered, according to the lab script, we should use routing but no layer 3 to layer 2 mapping to accomplish the task, but the answer provided did not.Here is my answer and some key points:

First, I have to introduce my lab. Because we don't have a 2509 or 2511 to act as terminal server right now, I used a 2505 instead. Each router connect its ethernet port to 2505's hub port, and configured with a secondary address of 129.1.1.0/24 as management address, It is a good idea, I can now telnet from a router (R7) to access the console, but I have to handle routing update carefully, preventing them be sending out the ethernet port, so as not to cause an 'Area ID mismatch' error.

Another question with my lab is that we don't have enough memory on 2522s to run a 12.1 image, so we still have 11.3 or older version run on some routers, one thing must not be ignored is you have to enable ip subnet-zero and ip classless because it wasn't the default setting.

As the lab script demanded, we don't use any 'frame-relay map ip' commands, since the default ospf network type on NBMA interface is non-broadcast, neighbor is manually set, with proper priority. I have to reboot some router to make R1 the DR.

As hints implies, we used ip policy route-map to modify the routes to give it an correct next-hop address. the policy route-map should be applied to incoming interface, for example s1 on R4 and E0 on R5. Since we testing the connectivity on the router, i.e. the ping packet is source from the router itself, we have to enable ' ip local policy route-map'.The route map must not modifying multicast traffic such as 224.0.0.5 and 224.0.0.6 for OSPF to work correctly.

I know my answer is far from perfect, any help from anybody is appreciated. Mail me at nnwh@163.net, thanks in advanced.

Detail configuration:

R1#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R1

!

enable password cisco

!

ip subnet-zero

!

!

!

interface Ethernet0

ip address 129.1.1.201 255.255.255.0 secondary

ip address 10.1.1.1 255.255.0.0

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation frame-relay

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

no fair-queue

!

interface Serial0.1 multipoint

ip address 10.10.1.1 255.255.0.0

no ip directed-broadcast

frame-relay interface-dlci 102;use frame-relay map ip and ip ospf network tho solve this in usu.

frame-relay interface-dlci 103

frame-relay interface-dlci 105

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

router ospf 1

passive-interface Ethernet0

network 10.1.1.1 0.0.0.0 area 1

network 10.10.1.1 0.0.0.0 area 0

neighbor 10.10.1.3 priority 1;I specified no priority to the neighbors of R1, after the router become DR, it assign a priority of 1 to its neighbors

neighbor 10.10.1.5 priority 1;Reboot neighbors to make R1 DR if needed

neighbor 10.10.1.3 priority 1

neighbor 10.10.1.2 priority 1

!

ip classless

!

!

line con 0

transport input none

line aux 0

line vty 0 4

password cisco

login

!

end

R2#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R2

!

enable secret 5 $1$Rs8H$DnN/UatNAxg3lCypfq7nO.

!

ip subnet-zero

!

!

!

interface Ethernet0

ip address 129.1.1.202 255.255.255.0 secondary

ip address 137.20.20.1 255.255.255.0

no ip directed-broadcast

ip policy route-map local;Policy applied to interface for incomming traffic

!

interface Serial0

ip address 10.10.1.2 255.255.0.0

no ip directed-broadcast

encapsulation frame-relay

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

no fair-queue

frame-relay interface-dlci 201

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

router ospf 1

passive-interface Ethernet0

network 10.10.1.2 0.0.0.0 area 0

network 137.20.20.1 0.0.0.0 area 10

neighbor 10.10.1.1 priority 1

default-information originate always metric 100 metric-type 1

!

ip local policy route-map local

;Policy applied to router-originated traffic

ip classless

!

access-list 101 permit ip any 224.0.0.0 15.255.255.255

route-map local permit 10

;Don't policy route multicast traffic

match ip address 101

!

route-map local permit 20

match ip address 102

;Only match ip address and match length is usable in policy routing

set ip next-hop 10.10.1.1

;You can use set default in , set in ter , set ip defa next-hop, set ip next-hop , set ip precedence , set ip tos in policy routing

!

!

line con 0

transport input none

line aux 0

line vty 0 4

password cisco

login

!

end

R3#sh run

Building configuration...

Current configuration:

!

version 11.2

no service udp-small-servers

no service tcp-small-servers

!

hostname R3

!

enable password cisco

!

ip subnet-zero;Check to ensure ip subnet-zero and ip classless is enable if you running an old image

no ip domain-lookup

!

interface Ethernet0

ip address 129.1.1.203 255.255.255.0

!

interface Serial0

ip address 10.10.1.3 255.255.0.0

encapsulation frame-relay

no fair-queue

frame-relay interface-dlci 301

!

interface Serial1

ip address 10.34.1.1 255.255.0.0

ip policy route-map s1

clockrate 64000

!

router ospf 1

network 10.10.1.3 0.0.0.0 area 0

network 10.34.1.1 0.0.0.0 area 3

neighbor 10.10.1.1 priority 1

area 3 virtual-link 10.44.2.1;The ip address is the neighbor's RID, not the interface address

!

ip local policy route-map local

ip classless

access-list 101 permit ip any 224.0.0.0 15.255.255.255

access-list 101 permit ip any host 10.34.1.1

access-list 101 permit ip any host 10.10.1.3

route-map s1 permit 10

match ip address 101

!

route-map s1 permit 20

set ip next-hop 10.10.1.1

!

route-map local permit 10

match ip address 101

!

route-map local permit 20

match ip address 102

set ip next-hop 10.10.1.1

!

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

end

R4#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug

 
 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
2023年上半年GDP全球前十五强
 百态   2023-10-24
美众议院议长启动对拜登的弹劾调查
 百态   2023-09-13
上海、济南、武汉等多地出现不明坠落物
 探索   2023-09-06
印度或要将国名改为“巴拉特”
 百态   2023-09-06
男子为女友送行,买票不登机被捕
 百态   2023-08-20
手机地震预警功能怎么开?
 干货   2023-08-06
女子4年卖2套房花700多万做美容:不但没变美脸,面部还出现变形
 百态   2023-08-04
住户一楼被水淹 还冲来8头猪
 百态   2023-07-31
女子体内爬出大量瓜子状活虫
 百态   2023-07-25
地球连续35年收到神秘规律性信号,网友:不要回答!
 探索   2023-07-21
全球镓价格本周大涨27%
 探索   2023-07-09
钱都流向了那些不缺钱的人,苦都留给了能吃苦的人
 探索   2023-07-02
倩女手游刀客魅者强控制(强混乱强眩晕强睡眠)和对应控制抗性的关系
 百态   2020-08-20
美国5月9日最新疫情:美国确诊人数突破131万
 百态   2020-05-09
荷兰政府宣布将集体辞职
 干货   2020-04-30
倩女幽魂手游师徒任务情义春秋猜成语答案逍遥观:鹏程万里
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案神机营:射石饮羽
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案昆仑山:拔刀相助
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案天工阁:鬼斧神工
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案丝路古道:单枪匹马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:与虎谋皮
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:李代桃僵
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:指鹿为马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:小鸟依人
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:千金买邻
 干货   2019-11-12
 
推荐阅读
 
 
 
>>返回首頁<<
 
靜靜地坐在廢墟上,四周的荒凉一望無際,忽然覺得,淒涼也很美
© 2005- 王朝網路 版權所有