clns routing
!
interface Loopback0
ip address 10.1.1.2 255.255.255.0
ip router isis
!
interface Serial1
ip address 192.1.1.2 255.255.255.0
ip router isis
!
router isis
net 49.0001.0000.0000.0002.00
!
IS-IS命令查看
R4#sh clns prot
源码:-------------------------
IS-IS Router:
System Id: 0000.0000.0002.00 IS-Type: level-1-2
Manual area address(es):
49.0001
Routing for area address(es):
49.0001
Interfaces supported by IS-IS:
Serial1 - IP
Loopback0 - IP
Redistribute:
static (on by default)
Distance for L2 CLNS routes: 110
RRR level: none
Generate narrow metrics: level-1-2
Accept narrow metrics: level-1-2
Generate wide metrics: none
Accept wide metrics: none
R4#sh clns neighbors detail
源码:-------------------------
System Id Interface SNPA State Holdtime Type Protocol
FR Se1 *HDLC* Up 25 L1L2 IS-IS
Area Address(es): 49.0001
IP Address(es): 192.1.1.1*
Uptime: 00:11:05
------------------------------
源码:-------------------------
R4#sh clns int s0
Serial0 is down, line protocol is down
CLNS protocol processing disabled
R4#sh clns int s1
Serial1 is up, line protocol is up
Checksums enabled, MTU 1500, Encapsulation HDLC
ERPDUs enabled, min. interval 10 msec.
RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
Congestion Experienced bit set at 4 packets
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 33 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x100
Level-1 Metric: 10, Priority: 64, Circuit ID: R4.00
Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 64, Circuit ID: R4.00
Number of active level-2 adjacencies: 1
Next IS-IS Hello in 1 seconds
------------------------------
源码:-------------------------
R4#sh isis topology
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
FR 10 FR Se1 *HDLC*
R4 --
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
FR 10 FR Se1 *HDLC*
R4 --
------------------------------
源码:-------------------------
R4#sh isis dat
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
FR.00-00 0x00000004 0x08E1 837 0/0/0
R4.00-00 * 0x00000003 0x02F8 808 0/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
FR.00-00 0x00000004 0x15D4 962 0/0/0
R4.00-00 * 0x00000003 0x0FEB 963 0/0/0
R4#sh isis data detail fr.00-00
源码:-------------------------
IS-IS Level-1 LSP FR.00-00
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
FR.00-00 0x00000004 0x08E1 654 0/0/0
Area Address: 49.0001
NLPID: 0xCC
Hostname: FR
IP Address: 10.1.1.1
Metric: 10 IP 10.1.1.0 255.255.255.0
Metric: 10 IP 192.1.1.0 255.255.255.0
Metric: 10 IS FR.01
Metric: 10 IS R4.00
IS-IS Level-2 LSP FR.00-00
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
FR.00-00 0x00000004 0x15D4 778 0/0/0
Area Address: 49.0001
NLPID: 0xCC
Hostname: FR
IP Address: 10.1.1.1
Metric: 10 IS FR.01
Metric: 10 IS R4.00
Metric: 10 IP 10.1.1.0 255.255.255.0
Metric: 10 IP 192.1.1.0 255.255.255.0-----------------
在IS-IS中通告默认路由
源码:-------------------------
FR#sh isis database detail R4.00-00
IS-IS Level-1 LSP R4.00-00
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R4.00-00 0x00000004 0xFFF9 583 0/0/0
Area Address: 49.0001
NLPID: 0xCC
Hostname: R4
IP Address: 10.1.1.2
Metric: 10 IP 10.1.1.0 255.255.255.0
Metric: 10 IP 192.1.1.0 255.255.255.0
Metric: 10 IS R4.01
Metric: 10 IS FR.00
IS-IS Level-2 LSP R4.00-00
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R4.00-00 0x00000008 0x4D1B 1078 0/0/0
Area Address: 49.0001
NLPID: 0xCC
Hostname: R4
IP Address: 10.1.1.2
Metric: 10 IS R4.01
Metric: 10 IS FR.00
Metric: 0 IP 0.0.0.0 0.0.0.0
Metric: 10 IP 10.1.1.0 255.255.255.0
Metric: 10 IP 192.1.1.0 255.255.255.0
------------------------------
静态路由重分配
源码:-------------------------
router isis
redistribute static ip metric 0 metric-type external
net 49.0001.0000.0000.0002.00
!
ip kerberos source-interface any
ip classless
ip route 172.16.0.0 255.255.0.0 Null0
R4#sh isis database detail R4.00-00
IS-IS Level-1 LSP R4.00-00
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R4.00-00 * 0x00000005 0xFDFA 1032 0/0/0
Area Address: 49.0001
NLPID: 0xCC
Hostname: R4
IP Address: 10.1.1.2
Metric: 10 IP 10.1.1.0 255.255.255.0
Metric: 10 IP 192.1.1.0 255.255.255.0
Metric: 10 IS R4.01
Metric: 10 IS FR.00
IS-IS Level-2 LSP R4.00-00
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R4.00-00 * 0x0000000A 0x5393 1167 0/0/0
Area Address: 49.0001
NLPID: 0xCC
Hostname: R4
IP Address: 10.1.1.2
Metric: 10 IS R4.01
Metric: 10 IS FR.00
Metric: 64 IP-External 172.16.0.0 255.255.0.0
Metric: 10 IP 10.1.1.0 255.255.255.0
Metric: 10 IP 192.1.1.0 255.255.255.0
--------------------------------------------------------------------------------
源码:--------------------------------------------------------------------------------
FR#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
i L2 172.16.0.0/16 [115/74] via 192.1.1.2, Serial0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
C 192.1.1.0/24 is directly connected, Serial0
--------------------------------------------------------------------------------
使用外部度量配置路由重分配
Building configuration...
Current configuration : 1012 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
logging rate-limit console 10 except errors
enable secret 5 $1$uQoR$j/4s6VMellnR9mt5nIzWE.
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
clns routing
!
interface Loopback0
ip address 10.1.1.2 255.255.255.0
ip router isis
!
interface Ethernet0
ip address 172.16.1.1 255.255.255.0
!