Changing the Version of WCCP on a Router Example
The following example shows the process of changing the WCCP version from the default of WCCPv2 to WCCPv1, starting in privileged EXEC mode:
router# show ip wccp
% WCCP version 2 is not enabled
router# configure terminal
router(config)#ip wccp version 1
router(config)#end
router# show ip wccp
% WCCP version 1 is not enabled
Performing a General WCCPv2 Configuration Example
The following example shows a general WCCP v2 configuration session:
router# configure terminal
router(config)# ip wccp web-cache group-address 224.1.1.100 password alaska1
router(config)# interface ethernet0
router(config-if)# ip wccp web-cache redirect out
Running a Web Cache Service Example
The following example shows a web cache service configuration session:
router# configure terminal
router(config)# ip wccp web-cache
router(config)# interface ethernet 0
router(config-if)# ip wccp web-cache redirect out
Running a Reverse Proxy Service Example
The following example assumes you a configuring a service group using Cisco Cache Engines, which use dynamic service 99 to run a reverse proxy service:
router# configure terminal
router(config)# ip wccp 99
router(config)# interface ethernet 0
router(config-if)# ip wccp 99 redirect out
Registering a Router to a Multicast Address Example
The following example shows how to register a router to a multicast address of 224.1.1.100:
router# configure terminal
router(config)# ip wccp web-cache group-address 224.1.1.100
router(config)# interface ethernet 0
router(config-if)# ip wccp web cache group-listen
Using Access Lists Example
To achieve better security, you can notify the router which IP addresses are valid addresses for a cache engine attempting to register with the current router, using a standard access list. The following example shows a standard access list configuration session where the access list number is 10 for some sample hosts:
router# configure terminal
router(config)# access-list 10 permit host 11.1.1.1
router(config)# access-list 10 permit host 11.1.1.2
router(config)# access-list 10 permit host 11.1.1.3
router(config)# ip wccp web-cache group-list 10
To disable caching for certain clients, servers, or client/server pairs, you can use WCCP access lists. The following example shows any requests coming from 10.1.1.1 to 12.1.1.1 will bypass the cache, while all other requests will be serviced normally:
router# configure terminal
router(config)# ip wccp web-cache redirect-list 120
router(config)# access-list 120 deny tcp host 10.1.1.1 any
router(config)# access-list 120 deny tcp any host 12.1.1.1
router(config)# access-list 120 permit ip any any
Setting a Password for a Router and Cache Engines Example
The following example shows a WCCP v2 password configuration session where the password is alaska1:
router# configure terminal
router(config)# ip wccp web-cache password alaska1
Verifying WCCP Settings Example
To verify your configuration changes, use the more system:running-config command. The following example shows that the both the Web-Cache Service and dynamic service 99 is enabled on the router:
router# more system:running-config
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname router4
!
enable secret 5 $1$nSVy$faliJsVQXVPW.KuCxZNTh1
enable password alabama1
!
ip subnet-zero
ip wccp web-cache
ip wccp 99
ip domain-name cisco.com
ip name-server 10.1.1.1
ip name-server 10.1.1.2
ip name-server 10.1.1.3
!
!
!
interface Ethernet0
ip address 10.3.1.2 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect out
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
interface Ethernet1
ip address 10.4.1.1 255.255.255.0
no ip directed-broadcast
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
interface Serial0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip default-gateway 10.3.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.1.1
no ip http server
!
!
!
line con 0
transport input none
line aux 0
transport input all
line vty 0 4
password alaska1
login
!
end
相关名词
Cisco Express Forwarding (CEF)―A scalable, distributed, Layer 3 switching solution designed to meet performance requirements of the Internet and enterprise networks. CEF can also refer to central CEF mode, one of the two modes of CEF operation that enables a route processor to perform express forwarding.
distributed CEF (dCEF)―One of two modes of CEF operation that enables line cards to perform the express forwarding between port adapters.
FIB―Forwarding information base
line card―A general term for an interface processor that can be used in a line of Cisco products. For example, a VIP is a line card for the Cisco 7500 series router.
netflow―A feature of some routers which allows them to categorize incoming packets into flows. As packets in a flow can often be treated in the same way, this classification can be used to bypass some of the work of the router and accelerate its switching operation.
service group―A group of routers and cache engines configured to run the same WCCP redirection service.
WCCP―Web Cache Communication Protocol. WCCP is a protocol for communication between routers and Web caches. Two versions currently exist: WCCP Version 1(WCCPv1) and WCCP Version 2 (WCCPv2). The two versions are incompatible. Cisco IOS images may support either of the two versions or both.