分享
 
 
 

TwoPE-ThreeCEConfigurationBGP-connectedCE

王朝other·作者佚名  2008-05-19
窄屏简体版  字體: |||超大  

CE1 Configuration

This is an example of the CE1 configuration.

hostname CE1

!

interface Ethernet0

ip address 172.16.1.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

encapsulation frame-relay

service module t1 clock source line

!

interface Serial0.1 point-to-point

frame-relay interface-dlci 123

ip address 10.101.1.2 255.255.255.252

no ip directed-broadcast

!

router ospf 100

redistribute bgp 101

network 172.16.0.0 0.0.255.255 area 100

!

router bgp 101

redistribute ospf 100

no synchronization

network 172.16.0.0

neighbor 10.101.1.1 remote-as 100

!

CE2 Configuration

This is an example of the CE2 configuration.

hostname CE2

!

interface Ethernet0

ip address 172.16.1.2 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

encapsulation frame-relay

service module t1 clock source line

!

interface Serial0.1 point-to-point

frame-relay interface-dlci 123

ip address 10.101.2.2 255.255.255.252

no ip directed-broadcast

!

router ospf 100

redistribute bgp 101

network 172.16.0.0 0.0.255.255 area 100

!

router bgp 101

redistribute ospf 100

no synchronization

network 172.16.0.0

neighbor 10.101.2.1 remote-as 100

!

CE3 Configuration

This is an example of the CE3 configuration.

hostname CE3

!

interface Ethernet0

ip address 172.16.3.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

encapsulation frame-relay

service module t1 clock source line

!

interface Serial0.1 point-to-point

frame-relay interface-dlci 123

ip address 10.101.3.2 255.255.255.252

no ip directed-broadcast

!

router ospf 100

redistribute bgp 101

network 172.16.0.0 0.0.255.255 area 100

!

router bgp 101

no synchronization

redistribute ospf 100

network 172.16.0.0

neighbor 10.101.3.1 remote-as 100

!

PE1 Configuration

This is an example of the PE1 configuration.

hostname RPM1

!

ip vrf vpn1 ! Define a VRF for VPN 1

rd 100:1

route-target export 100:1

route-target import 100:1

!

ip cef

!

interface loopback0

ip address 10.1.1.1 255.255.255.255

!

interface Switch1

no ip address

!

interface Switch1.1 tag-switching

ip unnumbered Loopback0

atm pvc 50 50 0 aal5snap vbr-nrt 10000 10000 64000

tag-switching atm vp-tunnel 50

tag-switching ip

!

router ospf 1

network 10.1.0.0 0.0.255.255 area 0

interface Switch1.101

ip address 10.101.1.1 255.255.255.252

pvc 0/101

encap aal5snap

vbr-nrt 1500 1500 64000

ip vrf forwarding vpn1

!

interface Switch1.102

ip address 10.101.2.1 255.255.255.252

pvc 0/102

encap aal5snap

vbr-nrt 1500 1500 64000

ip vrf forwarding vpn1

!

router bgp 100

no synchronization

no bgp default ipv4-unicast

neighbor 212.212.212.2 remote-as 100 !define BGP connection to PE2 for IPv4

neighbor 212.212.212.2 update-source Loopback0

!

address-family vpnv4 !define BGP connection to PE2 for VPN routes

neighbor 212.212.212.2 activate

neighbor 212.212.212.2 send-community extended

exit-address-family

!

address-family ipv4 vrf vpn1 ! Define BGP PE-CE sessions for vpn1

neighbor 10.101.1.2 remote-as 101

neighbor 10.101.1.2 activate

neighbor 10.101.2.2 remote-as 101

neighbor 10.101.2.2 activate

no auto-summary

no synchronization

exit-address-family

!

rpmrscprtn par 100 100 1 100 10 4000 3800

addconn vpc switch 1/1.1 50 rslot 0 1 50 master local

addcon vcc Switch1.101 101 rslot 18 1 0 123 master local

addcon vcc Switch1.102 102 rslot 18 2 0 123 master local

!

PE2 Configuration

This is an example of the PE2 configuration.

hostname RPM1

!

ip vrf vpn1 ! Define a VRF for VPN 1

rd 100:1

route-target export 100:1

route-target import 100:1

!

ip cef

!

interface loopback0

ip address 10.1.1.1 255.255.255.255

!

interface Switch1

no ip address

!

interface Switch1.1 tag-switching

ip unnumbered Loopback0

atm pvc 50 50 0 aal5snap vbr-nrt 10000 10000 64000

tag-switching atm vp-tunnel 50

tag-switching ip

!

router ospf 1

network 10.1.0.0 0.0.255.255 area 0

interface Switch1.101

ip address 10.101.3.1 255.255.255.252

pvc 0/101

encap aal5snap

vbr-nrt 1500 1500 64000

ip vrf forwarding vpn1

!

router bgp 100

no synchronization

no bgp default ipv4-unicast

neighbor 212.212.212.1 remote-as 100 !define BGP connection to PE1 for IPv4

neighbor 212.212.212.1 update-source Loopback0

!

address-family vpnv4 !define BGP connection to PE1 for VPN routes

neighbor 212.212.212.1 activate

neighbor 212.212.212.1 send-community extended

exit-address-family

!

address-family ipv4 vrf vpn1 ! Define BGP PE-CE3 session for vpn1

neighbor 10.101.3.2 remote-as 101

neighbor 10.101.3.2 activate

no auto-summary

no synchronization

exit-address-family

!

rpmrscprtn par 100 100 1 100 10 4000 3800

addconn vpc switch 1/1.1 50 rslot 0 1 50 master local

addcon vcc Switch1.101 101 rslot 18 1 0 123 master local

!

Two PE-Three CE Configuration, RIP-connected CE Routers

This is similar to the previous examples except that RIP is used between CE and PE routers. The use of RIP is not recommended when there are "back-door" routes between customer sites, for example, links between CEs, except through the VPN network.

CE1 Configuration

This is an example of the CE1 configuration.

hostname CE1

!

interface Ethernet0

ip address 172.16.1.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

encapsulation frame-relay

service module t1 clock source line

!

interface Serial0.1 point-to-point

frame-relay interface-dlci 123

ip address 10.101.1.2 255.255.255.252

no ip directed-broadcast

!

router rip

version 2

network 10.0.0.0

network 172.16.0.0

no auto-summary

!

CE2 Configuration

This is an example of the CE2 configuration.

hostname CE2

!

interface Ethernet0

ip address 172.16.2.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

encapsulation frame-relay

service module t1 clock source line

!

interface Serial0.1 point-to-point

frame-relay interface-dlci 123

ip address 10.101.2.2 255.255.255.252

no ip directed-broadcast

!

router rip

version 2

 
 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
2023年上半年GDP全球前十五强
 百态   2023-10-24
美众议院议长启动对拜登的弹劾调查
 百态   2023-09-13
上海、济南、武汉等多地出现不明坠落物
 探索   2023-09-06
印度或要将国名改为“巴拉特”
 百态   2023-09-06
男子为女友送行,买票不登机被捕
 百态   2023-08-20
手机地震预警功能怎么开?
 干货   2023-08-06
女子4年卖2套房花700多万做美容:不但没变美脸,面部还出现变形
 百态   2023-08-04
住户一楼被水淹 还冲来8头猪
 百态   2023-07-31
女子体内爬出大量瓜子状活虫
 百态   2023-07-25
地球连续35年收到神秘规律性信号,网友:不要回答!
 探索   2023-07-21
全球镓价格本周大涨27%
 探索   2023-07-09
钱都流向了那些不缺钱的人,苦都留给了能吃苦的人
 探索   2023-07-02
倩女手游刀客魅者强控制(强混乱强眩晕强睡眠)和对应控制抗性的关系
 百态   2020-08-20
美国5月9日最新疫情:美国确诊人数突破131万
 百态   2020-05-09
荷兰政府宣布将集体辞职
 干货   2020-04-30
倩女幽魂手游师徒任务情义春秋猜成语答案逍遥观:鹏程万里
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案神机营:射石饮羽
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案昆仑山:拔刀相助
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案天工阁:鬼斧神工
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案丝路古道:单枪匹马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:与虎谋皮
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:李代桃僵
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:指鹿为马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:小鸟依人
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:千金买邻
 干货   2019-11-12
 
推荐阅读
 
 
 
>>返回首頁<<
 
靜靜地坐在廢墟上,四周的荒凉一望無際,忽然覺得,淒涼也很美
© 2005- 王朝網路 版權所有