分享
 
 
 

【USACO--Section 1.1】 Problem 2

王朝other·作者佚名  2006-01-31
窄屏简体版  字體: |||超大  

Greedy Gift Givers

A group of NP (2 ≤ NP ≤ 10) uniquely named friends has decided to exchange gifts of money. Each of these friends might or might not give some money to any or all of the other friends. Likewise, each friend might or might not receive money from any or all of the other friends. Your goal in this problem is to deduce how much more money each person gives than they receive.

The rules for gift-giving are potentially different than you might expect. Each person sets aside a certain amount of money to give and divides this money evenly among all those to whom he or she is giving a gift. No fractional money is available, so dividing 3 among 2 friends would be 1 each for the friends with 1 left over -- that 1 left over stays in the giver's "account".

In any group of friends, some people are more giving than others (or at least may have more acquaintances) and some people have more money than others.

Given a group of friends, no one of whom has a name longer than 14 characters, the money each person in the group spends on gifts, and a (sub)list of friends to whom each person gives gifts, determine how much more (or less) each person in the group gives than they receive.

IMPORTANT NOTE

The grader machine is a Linux machine that uses standard Unix conventions: end of line is a single character often known as '\n'. This differs from Windows, which ends lines with two charcters, '\n' and '\r'. Do not let your program get trapped by this!

PROGRAM NAME: gift1

INPUT FORMAT

Line 1:

The single integer, NP

Lines 2..NP+1:

Each line contains the name of a group member

Lines NP+2..end:

NP groups of lines organized like this:

The first line in the group tells the person's name who will be giving gifts.

The second line in the group contains two numbers: The initial amount of money (in the range 0..2000) to be divided up into gifts by the giver and then the number of people to whom the giver will give gifts, NGi (0 ≤ NGi ≤ NP-1).

If NGi is nonzero, each of the next NGi lines lists the the name of a recipient of a gift.

SAMPLE INPUT (file gift1.in)

5

dave

laura

owen

vick

amr

dave

200 3

laura

owen

vick

owen

500 1

dave

amr

150 2

vick

owen

laura

0 2

amr

vick

vick

0 0

OUTPUT FORMAT

The output is NP lines, each with the name of a person followed by a single blank followed by the net gain or loss (final_money_value - initial_money_value) for that person. The names should be printed in the same order they appear on line 2 of the input.

All gifts are integers. Each person gives the same integer amount of money to each friend to whom any money is given, and gives as much as possible that meets this constraint. Any money not given is kept by the giver.

SAMPLE OUTPUT (file gift1.out)

dave 302

laura 66

owen -359

vick 141

amr -150

My Answer:

/*

ID: horisly1

PROG: gift1

LANG: C++

*/

#include <iostream>

#include <fstream>

#include <string>

#include <vector>

#include <map>

using namespace std;

class Friend {

private:

string m_sName;

int m_nMoney;

int m_nPerGift;

int m_nFriends;

int m_nTotalRecGift;

int m_nTotalGiveGift;

public:

Friend(string name):m_sName(name),m_nMoney(0),m_nFriends(0),m_nTotalRecGift(0),m_nTotalGiveGift(0) { }

void SetMoney(int money) {

m_nMoney = money;

}

void SetFriends(int n) {

m_nFriends = n;

}

void RecGift(int gift) {

m_nTotalRecGift += gift;

}

int GiveGift() {

if( m_nFriends == 0 || m_nMoney == 0 )

m_nPerGift = 0;

else {

m_nPerGift = m_nMoney / m_nFriends;

m_nTotalGiveGift = m_nPerGift * m_nFriends;

}

return m_nPerGift;

}

int GetTotalGiveGift() {

return m_nTotalGiveGift;

}

int GetTotalRecGift() {

return m_nTotalRecGift;

}

};

int main() {

ifstream fin ("gift1.in");

ofstream fout ("gift1.out");

int NP;

fin >> NP;

map<string,Friend> npMap;

vector<string> vName;

for(int i=0; i<NP; i++) {

string name;

fin >> name;

vName.push_back(name);

Friend f(name);

npMap.insert(make_pair(name,f));

}

map<string,Friend>::iterator pos;

for(int k=0; k<NP; k++) {

string szName;

fin >> szName;

pos = npMap.find(szName);

int money, n;

string szFriend;

fin >> money >> n;

pos->second.SetMoney(money);

pos->second.SetFriends(n);

int gift = pos->second.GiveGift();

map<string,Friend>::iterator p;

for(int i=0; i<n; i++) {

fin >> szFriend;

p = npMap.find(szFriend);

p->second.RecGift(gift);

}

}

for(int i=0; i<NP; i++) {

string name = vName[i];

map<string,Friend>::iterator p;

p = npMap.find(name);

int banlance = p->second.GetTotalRecGift() - p->second.GetTotalGiveGift();

fout << p->first << " " << banlance <<endl;

}

return 0;

}

The Answer of the website:

The hardest part about this problem is dealing with the strings representing people's names.

We keep an array of Person structures that contain their name and how much money they give/get.

The heart of the program is the lookup() function that, given a person's name, returns their Person structure. We add new people with addperson().

Note that we assume names are reasonably short.

#include <stdio.h>

#include <string.h>

#include <assert.h>

#define MAXPEOPLE 10

#define NAMELEN 32

typedef struct Person Person;

struct Person {

char name[NAMELEN];

int total;

};

Person people[MAXPEOPLE];

int npeople;

void

addperson(char *name)

{

assert(npeople < MAXPEOPLE);

strcpy(people[npeople].name, name);

npeople++;

}

Person*

lookup(char *name)

{

int i;

/* look for name in people table */

for(i=0; i<npeople; i++)

if(strcmp(name, people[i].name) == 0)

return &people[i];

assert(0); /* should have found name */

}

int

main(void)

{

char name[NAMELEN];

FILE *fin, *fout;

int i, j, np, amt, ng;

Person *giver, *receiver;

fin = fopen("gift1.in", "r");

fout = fopen("gift1.out", "w");

fscanf(fin, "%d", &np);

assert(np <= MAXPEOPLE);

for(i=0; i<np; i++) {

fscanf(fin, "%s", name);

addperson(name);

}

/* process gift lines */

for(i=0; i<np; i++) {

fscanf(fin, "%s %d %d", name, &amt, &ng);

giver = lookup(name);

for(j=0; j<ng; j++) {

fscanf(fin, "%s", name);

receiver = lookup(name);

giver->total -= amt/ng;

receiver->total += amt/ng;

}

}

/* print gift totals */

for(i=0; i<np; i++)

printf("%s %d\n", people[i].name, people[i].total);

exit (0);

}

 
 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
2023年上半年GDP全球前十五强
 百态   2023-10-24
美众议院议长启动对拜登的弹劾调查
 百态   2023-09-13
上海、济南、武汉等多地出现不明坠落物
 探索   2023-09-06
印度或要将国名改为“巴拉特”
 百态   2023-09-06
男子为女友送行,买票不登机被捕
 百态   2023-08-20
手机地震预警功能怎么开?
 干货   2023-08-06
女子4年卖2套房花700多万做美容:不但没变美脸,面部还出现变形
 百态   2023-08-04
住户一楼被水淹 还冲来8头猪
 百态   2023-07-31
女子体内爬出大量瓜子状活虫
 百态   2023-07-25
地球连续35年收到神秘规律性信号,网友:不要回答!
 探索   2023-07-21
全球镓价格本周大涨27%
 探索   2023-07-09
钱都流向了那些不缺钱的人,苦都留给了能吃苦的人
 探索   2023-07-02
倩女手游刀客魅者强控制(强混乱强眩晕强睡眠)和对应控制抗性的关系
 百态   2020-08-20
美国5月9日最新疫情:美国确诊人数突破131万
 百态   2020-05-09
荷兰政府宣布将集体辞职
 干货   2020-04-30
倩女幽魂手游师徒任务情义春秋猜成语答案逍遥观:鹏程万里
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案神机营:射石饮羽
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案昆仑山:拔刀相助
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案天工阁:鬼斧神工
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案丝路古道:单枪匹马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:与虎谋皮
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:李代桃僵
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:指鹿为马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:小鸟依人
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:千金买邻
 干货   2019-11-12
 
推荐阅读
 
 
 
>>返回首頁<<
 
靜靜地坐在廢墟上,四周的荒凉一望無際,忽然覺得,淒涼也很美
© 2005- 王朝網路 版權所有