ip rsvp bandwidth interface-kbps sub-pool kbps
For this specific example of an OC-3 with 150 Mbps in the global pool and 45 Mbps in the subpool, the necessary configuration is as follows:
ip rsvp bandwidth 150000 sub-pool 45000
class-map match-all voice
match mpls eXPerimental 5
policy-map llq
class voice
priority percent 30
interface POS3/0
service-policy output llq
tunnel mpls traffic-eng bandwidth sub-pool kbps
This is the same thing as the tunnel mpls traffic-eng bandwidth kbps command that was covered earlier in this book, except that you are telling the headend to do its path calculation and bandwidth reservation based on the advertised subpool bandwidth.
You are allowed to have only one type of reservation per tunnel. If you try to configure a tunnel with the command tunnel mpls traffic-eng bandwidth followed by the command tunnel mpls traffic-eng bandwidth sub-pool, the sub-pool command overwrites the global pool command.
H3 and H4 Can Be Reached Over Both TE Tunnels
源码:--------------------------------------------------------------------------------
On the CPE:
router bgp 100
neighbor 4.4.4.4 route-map setcom-voice out
route-map setcom-voice
match ip address 101
set community 1:1
Access-list 101 permit ip host 1.1.1.1 host 255.255.255.255
On RouterG (the tunnel tail)
router bgp 100
neighbor 1.2.3.4 route-map set-nh in
route-map set-nh
match community 1
set ip next-hop 5.5.5.5
ip community-list 1 permit 1:1
On Routers A, B, C, and D
ip route 5.5.5.5 255.255.255.255 Tunnel1