跟GRE差不多,只不过是2层的,相当于两个ipv6的接口直连了,扩展性也不好。另外除了l2tpv3,EoMPLS也是个选择。
R1
hostname R1
!
interface Ethernet1/2
no ip address
duplex full
ipv6 enable
R2
hostname R2
!
pseudowire-class l2tpv3dynamic
encapsulation l2tpv3
ip local interface Loopback0
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet1/1
no ip address
duplex full
no cdp enable
xconnect 3.3.3.3 1 encapsulation l2tpv3 pw-class l2tpv3dynamic
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 192.168.0.0 0.0.255.255 area 0
R3
hostname R3
!
pseudowire-class l2tpv3dynamic
encapsulation l2tpv3
ip local interface Loopback0
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet1/2
ip address 192.168.23.3 255.255.255.0
duplex full
!
interface Ethernet1/4
no ip address
duplex full
no cdp enable
xconnect 2.2.2.2 1 encapsulation l2tpv3 pw-class l2tpv3dynamic
!
router ospf 100
router-id 3.3.3.3
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 192.168.0.0 0.0.255.255 area 0
R4
hostname R4
!
interface Ethernet1/3
no ip address
duplex full
ipv6 enable
R4#sho ipv6 int e1/3
Ethernet1/3 is up, line PRotocol is up
IPv6 is enabled, link-local address is FE80::C800:31FF:FEB1:1F
No global unicast address is configured
Joined group address(es):
FF02::1
FF02::2
FF02::1:FFB1:1F
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
R1#ping ipv6 FE80::C800:31FF:FEB1:1F
Output Interface: ethernet1/2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::C800:31FF:FEB1:1F, timeout is 2 seconds:
Packet sent with a source address of FE80::C800:31FF:FEB5:1E
!!!!!
SUCcess rate is 100 percent (5/5), round-trip min/avg/max = 232/676/1444 ms