原理:
R1
hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
no ip address
ipv6 address FC00:1::1/128
ipv6 enable
!
interface Ethernet1/2
no ip address
duplex full
ipv6 address FC00:12::1/32
ipv6 enable
!
ipv6 route ::/0 FC00:12::2
R2
hostname R2
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
mpls label PRotocol ldp
mpls ipv6 source-interface Loopback0
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ipv6 address FC00:2::2/128
ipv6 enable
!
interface Ethernet1/1
no ip address
duplex full
ipv6 address FC00:12::2/32
ipv6 enable
!
interface Ethernet1/3
ip address 192.168.23.2 255.255.255.0
duplex full
mpls ip
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 192.168.0.0 0.0.255.255 area 0
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
!
address-family ipv6
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-label
redistribute connected
redistribute static
no synchronization
exit-address-family
!
ipv6 route FC00:1::1/128 FC00:12::1
!
mpls ldp router-id Loopback0
R3
hostname R3
!
ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet1/2
ip address 192.168.23.3 255.255.255.0
duplex full
mpls ip
!
interface Ethernet1/4
ip address 192.168.34.3 255.255.255.0
duplex full
mpls ip
!
router ospf 100
router-id 3.3.3.3
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 192.168.0.0 0.0.255.255 area 0
!
mpls ldp router-id Loopback0
R4
hostname R4
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
mpls label protocol ldp
mpls ipv6 source-interface Loopback0
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ipv6 address FC00:4::4/128
ipv6 enable
!
interface Ethernet1/3
ip address 192.168.34.4 255.255.255.0
duplex full
mpls ip
!
interface Ethernet1/5
no ip address
duplex full
ipv6 address FC00:45::4/32
ipv6 enable
!
router ospf 100
router-id 4.4.4.4
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 192.168.0.0 0.0.255.255 area 0
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
!
address-family ipv6
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-label
redistribute connected
redistribute static
no synchronization
exit-address-family
!
ipv6 route FC00:5::5/128 FC00:45::5
!
mpls ldp router-id Loopback0
R5
hostname R5
!
ipv6 unicast-routing
!
interface Loopback0
no ip address
ipv6 address FC00:5::5/128
ipv6 enable
!
interface Ethernet1/4
no ip address
duplex full
ipv6 address FC00:45::5/32
ipv6 enable
!
ipv6 route ::/0 FC00:45::4