分享
 
 
 

Cisco IOS Cookbook 中文精简版第二十六章MPLS

王朝other·作者佚名  2008-05-31
窄屏简体版  字體: |||超大  

26.1. 配置基本的MPLS P路由器

提问 配置MPLS核心网络里面的P路由器

回答

Router-P1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-P1(config)#ip cef

Router-P1(config)#mpls ip

Router-P1(config)#interface FastEthernet0/0

Router-P1(config-if)#description connection to Router-PE2

Router-P1(config-if)#ip address 10.1.2.11 255.255.255.0

Router-P1(config-if)#mpls ip

Router-P1(config-if)#exit

Router-P1(config)#interface Serial0/0

Router-P1(config-if)#description connection to Router-PE1

Router-P1(config-if)#ip address 10.1.1.14 255.255.255.252

Router-P1(config-if)#mpls ip

Router-P1(config-if)#exit

Router-P1(config)#interface Serial0/1

Router-P1(config-if)#description connection to Router-PE3

Router-P1(config-if)#ip address 10.1.1.10 255.255.255.252

Router-P1(config-if)#mpls ip

Router-P1(config-if)#exit

Router-P1(config)#interface Loopback0

Router-P1(config-if)#ip address 10.0.0.11 255.255.255.255

Router-P1(config-if)#exit

Router-P1(config)#router ospf 99

Router-P1(config-router)#router-id 10.0.0.11

Router-P1(config-router)#network 10.0.0.0 0.255.255.255 area 0

Router-P1(config-router)#exit

Router-P1(config)#end

Router-P1#

注释 对于P路由器就是启用CEF和在端口启用MPLS,对于tag-switching ip instead 和mpls ip两个命令都基本一致,对于是否配置ldp或者tdp也不是必要的,路由器会自动适应。有三个验证命令:

Router-P1#show mpls interfaces

Interface IP Tunnel Operational

FastEthernet0/0 Yes (tdp) No Yes

Serial0/0 Yes (tdp) No Yes

Serial0/1 Yes (tdp) No Yes

Router-P1#show mpls ldp neighbor

Peer TDP Ident: 10.0.0.2:0; Local TDP Ident 10.0.0.11:0

TCP connection: 10.0.0.2.711 - 10.0.0.11.28185

State: Oper; PIEs sent/rcvd: 0/82; Downstream

Up time: 01:04:45

TDP discovery sources:

Serial0/0, Src IP addr: 10.1.1.13

Addresses bound to peer TDP Ident:

10.0.0.2 10.1.1.2 10.1.1.13

Router-P1#show mpls forwarding-table

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 Pop tag 10.0.0.2/32 7697 Se0/0 point2point

17 Pop tag 10.1.1.0/30 0 Se0/0 point2point

18 Pop tag 10.0.0.3/32 6685 Se0/1 point2point

进入讨论组讨论。

26.2. 配置基本的MPLS PE路由器

提问 配置MPLS网络的运营商边界路由器来互联用户网络

回答

配置三台PE路由器

Router-PE1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE1(config)#ip cef

Router-PE1(config)#mpls ip

Router-PE1(config)#interface Serial0/0

Router-PE1(config-if)#description Connection to Router-P1

Router-PE1(config-if)#ip address 10.1.1.13 255.255.255.252

Router-PE1(config-if)#mpls ip

Router-PE1(config-if)#exit

Router-PE1(config)#interface Loopback0

Router-PE1(config-if)#ip address 10.0.0.2 255.255.255.255

Router-PE1(config-if)#exit

Router-PE1(config)#router ospf 99

Router-PE1(config-router)#router-id 10.0.0.2

Router-PE1(config-router)#network 10.0.0.0 0.255.255.255 area 0

Router-PE1(config-router)#exit

Router-PE1(config)#ip vrf NetworkA

Router-PE1(config-vrf)#rd 100:1

Router-PE1(config-vrf)#route-target eXPort 100:1

Router-PE1(config-vrf)#route-target import 100:1

Router-PE1(config-vrf)#exit

Router-PE1(config)#ip vrf NetworkB

Router-PE1(config-vrf)#rd 100:2

Router-PE1(config-vrf)#route-target export 100:2

Router-PE1(config-vrf)#route-target import 100:2

Router-PE1(config-vrf)#exit

Router-PE1(config)#interface Ethernet0/0

Router-PE1(config-if)#description connection to customer A, site 1

Router-PE1(config-if)#ip vrf forwarding NetworkA

Router-PE1(config-if)#ip address 192.168.1.1 255.255.255.0

Router-PE1(config-if)#exit

Router-PE1(config)#interface Ethernet0/1

Router-PE1(config-if)#description connection to customer B, site 1

Router-PE1(config-if)#ip vrf forwarding NetworkB

Router-PE1(config-if)#ip address 192.168.11.1 255.255.255.0

Router-PE1(config-if)#exit

Router-PE1(config)#router bgp 100

Router-PE1(config-router)#bgp log-neighbor-changes

Router-PE1(config-router)#neighbor 10.0.0.3 remote-as 100

Router-PE1(config-router)#neighbor 10.0.0.3 update-source Loopback0

Router-PE1(config-router)#neighbor 10.0.0.4 remote-as 100

Router-PE1(config-router)#neighbor 10.0.0.4 update-source Loopback0

Router-PE1(config-router)#address-family ipv4 vrf NetworkA

Router-PE1(config-router-af)#no auto-summary

Router-PE1(config-router-af)#no synchronization

Router-PE1(config-router-af)#redistribute connected

Router-PE1(config-router-af)#exit-address-family

Router-PE1(config-router)#adress-family ipv4 vrf NetworkB

Router-PE1(config-router-af)#no auto-summary

Router-PE1(config-router-af)#no synchronization

Router-PE1(config-router-af)#redistribute connected

Router-PE1(config-router-af)#exit-address-family

Router-PE1(config-router)#address-family vpnv4

Router-PE1(config-router-af)#neighbor 10.0.0.3 activate

Router-PE1(config-router-af)#neighbor 10.0.0.3 send-community extended

Router-PE1(config-router-af)#neighbor 10.0.0.4 activate

Router-PE1(config-router-af)#neighbor 10.0.0.4 send-community extended

Router-PE1(config-router-af)#exit-address-family

Router-PE1(config-router)#exit

Router-PE1(config)#end

Router-PE1#

Router-PE2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE2(config)#ip cef

Router-PE2(config)#mpls ip

Router-PE2(config)#interface FastEthernet0/0

Router-PE2(config-if)#no ip address

Router-PE2(config-if)#exit

Router-PE2(config)#interface FastEthernet0/0.1

Router-PE2(config-if)#description Connection to Router-P1

Router-PE2(config-if)#encapsulation dot1Q 10

Router-PE2(config-if)#ip address 10.1.2.4 255.255.255.0

Router-PE2(config-if)#mpls ip

Router-PE2(config-if)#exit

Router-PE2(config)#interface Loopback0

Router-PE2(config-if)#ip address 10.0.0.3 255.255.255.255

Router-PE2(config-if)#exit

Router-PE2(config)#router ospf 99

Router-PE2(config-router)#router-id 10.0.0.3

Router-PE2(config-router)#network 10.0.0.0 0.255.255.255 area 0

Router-PE2(config-router)#exit

Router-PE2(config)#ip vrf NetworkA

Router-PE2(config-vrf)#rd 100:1

Router-PE2(config-vrf)#route-target export 100:1

Router-PE2(config-vrf)#route-target import 100:1

Router-PE2(config-vrf)#exit

Router-PE2(config)#ip vrf NetworkB

Router-PE2(config-vrf)#rd 100:2

Router-PE2(config-vrf)#route-target export 100:2

Router-PE2(config-vrf)#route-target import 100:2

Router-PE2(config-vrf)#exit

Router-PE2(config)#interface FastEthernet0/0.2

Router-PE2(config-if)#description Connection to customer A, site 2

Router-PE2(config-if)#encapsulation dot1Q 102

Router-PE2(config-if)#ip address 192.168.3.1 255.255.255.0

Router-PE2(config-if)#mpls ip

Router-PE2(config-if)#exit

Router-PE2(config)#router bgp 100

Router-PE2(config-router)#bgp log-neighbor-changes

Router-PE2(config-router)#neighbor 10.0.0.2 remote-as 100

Router-PE2(config-router)#neighbor 10.0.0.2 update-source Loopback0

Router-PE2(config-router)#neighbor 10.0.0.3 remote-as 100

Router-PE2(config-router)#neighbor 10.0.0.3 update-source Loopback0

Router-PE2(config-router)#address-family ipv4 vrf NetworkA

Router-PE2(config-router-af)#no auto-summary

Router-PE2(config-router-af)#no synchronization

Router-PE2(config-router-af)#redistribute connected

Router-PE2(config-router-af)#exit-address-family

Router-PE2(config-router)#address-family vpnv4

Router-PE2(config-router-af)#neighbor 10.0.0.2 activate

Router-PE2(config-router-af)#neighbor 10.0.0.2 send-community extended

Router-PE2(config-router-af)#neighbor 10.0.0.4 activate

Router-PE2(config-router-af)#neighbor 10.0.0.4 send-community extended

Router-PE2(config-router-af)#exit-address-family

Router-PE2(config-router)#exit

Router-PE2(config)#end

Router-PE2#

Router-PE3#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE3(config)#ip cef

Router-PE3(config)#mpls ip

Router-PE3(config)#interface Serial0/0

Router-PE3(config-if)#description Connection to Router-P1

Router-PE3(config-if)#ip address 10.1.1.9 255.255.255.252

Router-PE3(config-if)#mpls ip

Router-PE3(config-if)#exit

Router-PE3(config)#interface Loopback0

Router-PE3(config-if)#ip address 10.0.0.3 255.255.255.255

Router-PE3(config-if)#exit

Router-PE3(config)#router ospf 99

Router-PE3(config-router)#router-id 10.0.0.3

Router-PE3(config-router)#network 10.0.0.0 0.255.255.255 area 0

Router-PE3(config-router)#exit

Router-PE3(config)#ip vrf NetworkA

Router-PE3(config-vrf)#rd 100:1

Router-PE3(config-vrf)#route-target export 100:1

Router-PE3(config-vrf)#route-target import 100:1

Router-PE3(config-vrf)#exit

Router-PE3(config)#ip vrf NetworkB

Router-PE3(config-vrf)#rd 100:2

Router-PE3(config-vrf)#route-target export 100:2

Router-PE3(config-vrf)#route-target import 100:2

Router-PE3(config-vrf)#exit

Router-PE3(config)#interface Ethernet0/0

Router-PE3(config-if)#description connection to customer A, site 3

Router-PE3(config-if)#ip vrf forwarding NetworkA

Router-PE3(config-if)#ip address 192.168.2.1 255.255.255.0

Router-PE3(config-if)#exit

Router-PE3(config)#interface Ethernet0/1

Router-PE3(config-if)#description connection to customer B, site 2

Router-PE3(config-if)#ip vrf forwarding NetworkB

Router-PE3(config-if)#ip address 192.168.10.1 255.255.255.0

Router-PE3(config-if)#exit

Router-PE3(config)#router bgp 100

Router-PE3(config-router)#bgp log-neighbor-changes

Router-PE3(config-router)#neighbor 10.0.0.2 remote-as 100

Router-PE3(config-router)#neighbor 10.0.0.2 update-source Loopback0

Router-PE3(config-router)#neighbor 10.0.0.4 remote-as 100

Router-PE3(config-router)#neighbor 10.0.0.4 update-source Loopback0

Router-PE3(config-router)#address-family ipv4 vrf NetworkA

Router-PE3(config-router-af)#no auto-summary

Router-PE3(config-router-af)#no synchronization

Router-PE3(config-router-af)#redistribute connected

Router-PE3(config-router-af)#exit-address-family

Router-PE3(config-router)#adress-family ipv4 vrf NetworkB

Router-PE3(config-router-af)#no auto-summary

Router-PE3(config-router-af)#no synchronization

Router-PE3(config-router-af)#redistribute connected

Router-PE3(config-router-af)#exit-address-family

Router-PE3(config-router)#address-family vpnv4

Router-PE3(config-router-af)#neighbor 10.0.0.2 activate

Router-PE3(config-router-af)#neighbor 10.0.0.2 send-community extended

Router-PE3(config-router-af)#neighbor 10.0.0.4 activate

Router-PE3(config-router-af)#neighbor 10.0.0.4 send-community extended

Router-PE3(config-router-af)#exit-address-family

Router-PE3(config-router)#exit

Router-PE3(config)#end

Router-PE3#

注释 对于PE路由器首先是类似P路由器的基本MPLS配置,然后是配置了两个客户网络的VRF,其中rd用来作为MP BGP发布此VRF路由的标签,route target用来告诉MP BGP那个rd与之共享路由。在关联接口和VRF的时候要先配置ip vrf forwarding命令然后配置IP地址,通过show ip vrf来验证。然后就是MP-BGP的配置,这里和平常BGP配置最大的不同就是必须有send-community extended的配置,因为VRF的信息是通过这个值来宣告的,两个验证命令show ip route vrf NetworkA和ping vrf NetworkA 192.168.2.9 source 192.168.1.1

进入讨论组讨论。

26.3. 配置基本的MPLS CE路由器

提问 配置客户网络的边界路由器

回答

Router-CE-A1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A1(config)#interface FastEthernet0/0.1

Router-CE-A1(config-if)#encapsulation dot1Q 101

Router-CE-A1(config-if)#ip address 192.168.1.5 255.255.255.0

Router-CE-A1(config-if)#exit

Router-CE-A1(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1

Router-CE-A1(config)# exit

Router-CE-A1#

注释 CE路由器没有非凡的配置,只是需要到MPLS网络的路由而已,这里使用的是静态路由,使用其他动态路由协议也可以,这样两个不同的站点可以互通路由表

26.4. 配置ATM网络的MPLS

提问 配置运行于ATM网络上的MPLS

回答

根据ATM交换机性能的不同大概有两种配置,一种是不参与MPLS只是基本的信元传递

Router-PE1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE1(config)#ip cef

Router-PE1(config)#mpls ip

Router-PE1(config)#interface ATM1/0

Router-PE1(config-if)#no ip address

Router-PE1(config-if)#exit

Router-PE1(config)#interface ATM1/0.1 mpls

Router-PE1(config-if)#ip address 10.1.1.2 255.255.255.252

Router-PE1(config-if)#mpls ip

Router-PE1(config-if)#exit

Router-PE1(config)#end

Router-PE1#

Router-PE3#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE3(config)#ip cef

Router-PE3(config)#mpls ip

Router-PE3(config)#interface ATM1/0

Router-PE3(config-if)#no ip address

Router-PE3(config-if)#exit

Router-PE3(config)#interface ATM1/0.1 mpls

Router-PE3(config-if)#ip address 10.1.1.1 255.255.255.252

Router-PE3(config-if)#mpls ip

Router-PE3(config-if)#exit

Router-PE3(config)#end

Router-PE3#

ATM switch 交换机需要配置两个PVCs: 一个用于控制VC一个用户数据VC:

Switch-P2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch-P2(config)#interface ATM0/1/2

Switch-P2(config-if)#no ip address

Switch-P2(config-if)#exit

Switch-P2(config)#interface ATM0/1/3

Switch-P2(config-if)#no ip address

Switch-P2(config-if)#atm pvc 0 32 interface ATM0/1/2 0 32

Switch-P2(config-if)#atm pvc 1 33 interface ATM0/1/2 1 33

Switch-P2(config-if)#exit

Switch-P2(config)#end

Switch-P2#

另一种新的ATM交换机可以参与类似P路由器那样的MPLS包转发

Router-PE1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE1(config)#ip cef

Router-PE1(config)#mpls ip

Router-PE1(config)#interface ATM1/0

Router-PE1(config-if)#no ip address

Router-PE1(config-if)#exit

Router-PE1(config)#interface ATM1/0.1 mpls

Router-PE1(config-if)#ip address 10.1.1.2 255.255.255.252

Router-PE1(config-if)#mpls ip

Router-PE1(config-if)#exit

Router-PE1(config)#end

Router-PE1#

Router-PE3#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE3(config)#ip cef

Router-PE3(config)#mpls ip

Router-PE3(config)#interface ATM1/0

Router-PE3(config-if)#no ip address

Router-PE3(config-if)#exit

Router-PE3(config)#interface ATM1/0.1 mpls

Router-PE3(config-if)#ip address 10.1.1.6 255.255.255.252

Router-PE3(config-if)#mpls ip

Router-PE3(config-if)#exit

Router-PE3(config)#end

Router-PE3#

Switch-P2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch-P2(config)#ip cef

Switch-P2(config)#mpls ip

Switch-P2(config)#interface ATM0/1/2

Switch-P2(config-if)#ip address 10.1.1.5 255.255.255.252

Switch-P2(config-if)#mpls ip

Switch-P2(config-if)#exit

Switch-P2(config)#interface ATM0/1/3

Switch-P2(config-if)#ip address 10.1.1.1 255.255.255.252

Switch-P2(config-if)#mpls ip

Switch-P2(config-if)#exit

Switch-P2(config)#interface Loopback0

Switch-P2(config-if)#ip address 10.0.0.1 255.255.255.255

Switch-P2(config-if)#exit

Switch-P2(config)#router ospf 99

Switch-P2(config-router)#router-id 10.0.0.1

Switch-P2(config-router)#network 10.0.0.0 0.255.255.255 area 0

Switch-P2(config-router)#exit

Switch-P2(config)#end

Switch-P2#

注释 注重这里的配置是不全的是,只是和ATM有关的配置。第一种方式由于VC的配置所以扩展性不强,而另一种参与了IGP所以增强了扩展性

进入讨论组讨论。

26.5. PE-CE 之间运行RIP

提问 PE和CE路由器之间启用RIP路由协议

回答

Router-CE-A2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A2(config)#router rip

Router-CE-A2(config-router)#version 2

Router-CE-A2(config-router)#network 10.0.0.0

Router-CE-A2(config-router)#network 192.168.3.0

Router-CE-A2(config-router)#end

Router-CE-A2#

Router-PE2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE2(config)#router rip

Router-PE2(config-router)#version 2

Router-PE2(config-router)#address-family ipv4 vrf NetworkA

Router-PE2(config-router-af)#version 2

Router-PE2(config-router-af)#redistribute bgp 100 metric 4

Router-PE2(config-router-af)#network 192.168.3.0

Router-PE2(config-router-af)#exit-address-family

Router-PE2(config-router)#exit

Router-PE2(config)#router bgp 100

Router-PE2(config-router)#address-family ipv4 vrf NetworkA

Router-PE2(config-router-af)#redistribute rip metric 4

Router-PE2(config-router-af)#end

Router-PE2#

注释 这里需要注重的是RIP不是全局启用的,只是在特定的VRF下面的配置address-family ipv4 vrf NetworkA,另外需要配置RIP和MP-BGP之间的路由再分布。这里的再分布和传统再分布不同的是,分布到IGP的路由不是标记为外部路由的

26.6. PE-CE之间运行OSPF

提问 PE和CE路由器之间启用OSPF路由协议

回答

两个不同站点的CE路由器

Router-CE-A1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A1(config)#router ospf 55

Router-CE-A1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router-CE-A1(config-router)#network 192.168.5.0 0.0.0.255 area 0

Router-CE-A1(config-router)#end

Router-CE-A1#

Router-CE-A2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A2(config)#router ospf 55

Router-CE-A2(config-router)#network 192.168.3.0 0.0.0.255 area 0

Router-CE-A2(config-router)#end

Router-CE-A2#

两个相应站点的PE路由器

Router-PE1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE1(config)#router ospf 155 vrf NetworkA

Router-PE1(config-router)#redistribute bgp 100 subnets

Router-PE1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router-PE1(config-router)#exit

Router-PE1(config)#router bgp 100

Router-PE1(config-router)#address-family ipv4 vrf NetworkA

Router-PE1(config-router-af)#redistribute ospf 155

Router-PE1(config-router-af)#exit-address-family

Router-PE1(config-router)#end

Router-PE1#

Router-PE2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE2(config)#router ospf 155 vrf NetworkA

Router-PE2(config-router)#redistribute bgp 100 subnets

Router-PE2(config-router)#network 192.168.3.0 0.0.0.255 area 0

Router-PE2(config-router)#exit

Router-PE2(config)#router bgp 100

Router-PE2(config-router)#address-family ipv4 vrf NetworkA

Router-PE2(config-router-af)#redistribute ospf 155

Router-PE2(config-router-af)#exit-address-family

Router-PE2(config-router)#end

Router-PE2#

注释 这里只是和路由相关的配置,其他配置略去。12.2(8)T以后有shamlink这种特性来通过类似虚拟链路的方式修改OSPF的路由条目,从inter-area路由变为intra-area路由,

Router-PE1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE1(config)#interface Loopback155

Router-PE1(config-if)#ip vrf forwarding NetworkA

Router-PE1(config-if)#ip address 192.168.155.1 255.255.255.255

Router-PE1(config-if)#exit

Router-PE1(config)#router ospf 155 vrf NetworkA

Router-PE1(config-router)#area 0 sham-link 192.168.155.1 192.168.155.2 cost 10

Router-PE1(config-router)#redistribute bgp 100 subnets

Router-PE1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router-PE1(config-router)#end

Router-PE1#

Router-PE2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE2(config)#interface Loopback155

Router-PE2(config-if)#ip vrf forwarding NetworkA

Router-PE2(config-if)#ip address 192.168.155.2 255.255.255.255

Router-PE2(config-if)#exit

Router-PE2(config)#router ospf 155 vrf NetworkA

Router-PE2(config-router)#area 0 sham-link 192.168.155.2 192.168.155.1 cost 10

Router-PE2(config-router)#redistribute bgp 100 subnets

Router-PE2(config-router)#network 192.168.3.0 0.0.0.255 area 0

Router-PE2(config-router)#end

Router-PE2#

26.7. PE-CE之间运行EIGRP

提问 PE和CE路由器之间启用EIGRP路由协议

回答

Router-CE-A1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A1(config)#router eigrp 156

Router-CE-A1(config-router)#network 192.168.1.0

Router-CE-A1(config-router)#network 192.168.5.0

Router-CE-A1(config-router)#no auto-summary

Router-CE-A1(config-router)#end

Router-CE-A1#

Router-CE-A2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A2(config)#router eigrp 156

Router-CE-A2(config-router)#network 10.0.0.0

Router-CE-A2(config-router)#network 192.168.3.0

Router-CE-A2(config-router)#no auto-summary

Router-CE-A2(config-router)#end

Router-CE-A2#

Router-PE1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE1(config)#router eigrp 1001

Router-PE1(config-router)#no auto-summary

Router-PE1(config-router)#address-family ipv4 vrf NetworkA

Router-PE1(config-router-af)#redistribute bgp 100 metric 10000 10 255 1 1500

Router-PE1(config-router-af)#network 192.168.1.0

Router-PE1(config-router-af)#no auto-summary

Router-PE1(config-router-af)#autonomous-system 156

Router-PE1(config-router-af)#exit-address-family

Router-PE1(config-router)#exit

Router-PE1(config)#router bgp 100

Router-PE1(config-router)#address-family ipv4 vrf NetworkA

Router-PE1(config-router-af)#redistribute eigrp 156

Router-PE1(config-router-af)#exit-address-family

Router-PE1(config-router)#exit

Router-PE1(config)#end

Router-PE1#

Router-PE2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE2(config)#router eigrp 1001

Router-PE2(config-router)#auto-summary

Router-PE2(config-router)#address-family ipv4 vrf NetworkA

Router-PE2(config-router-af)#redistribute bgp 100 metric 10000 10 255 1 1500

Router-PE2(config-router-af)#network 192.168.3.0

Router-PE2(config-router-af)#no auto-summary

Router-PE2(config-router-af)#autonomous-system 156

Router-PE2(config-router-af)#exit-address-family

Router-PE2(config-router)#end

Router-PE2#

注释 注重的是VRF中自治域系统的配置和相应再分发是选择的AS配置,要确保PE和CE的一致,对PE这里有两个EIGRP的AS号

进入讨论组讨论。

26.8. PE-CE之间运行BGP

提问 PE和CE路由器之间启用BGP路由协议

回答

Router-CE-A1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A1(config)#router bgp 65535

Router-CE-A1(config-router)#neighbor 192.168.1.1 remote-as 100

Router-CE-A1(config-router)#redistribute ospf 155

Router-CE-A1(config-router)#no synchronization

Router-CE-A1(config-router)#no auto-summary

Router-CE-A1(config-router)#exit

Router-CE-A1(config)#router ospf 155

Router-CE-A1(config-router)#redistribute bgp 65535 subnets

Router-CE-A1(config-router)#network 192.168.5.0 0.0.0.255 area 0

Router-CE-A1(config-router)#end

Router-CE-A1#

Router-CE-A2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A2(config)#router bgp 65534

Router-CE-A2(config-router)#neighbor 192.168.3.1 remote-as 100

Router-CE-A2(config-router)#network 10.8.8.0 mask 255.255.255.0

Router-CE-A2(config-router)#network 192.168.3.0

Router-CE-A2(config-router)#no synchronization

Router-CE-A2(config-router)#no auto-summary

Router-CE-A2(config-router)#end

Router-CE-A2#

Router-PE1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE1(config)#router bgp 100

Router-PE1(config-router)#address-family ipv4 vrf NetworkA

Router-PE1(config-router-af)#neighbor 192.168.1.5 remote-as 65535

Router-PE1(config-router-af)#neighbor 192.168.1.5 activate

Router-PE1(config-router-af)#end

Router-PE1#

Router-PE2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE2(config)#router bgp 100

Router-PE2(config-router)#address-family ipv4 vrf NetworkA

Router-PE2(config-router-af)#neighbor 192.168.3.8 remote-as 65534

Router-PE2(config-router-af)#neighbor 192.168.3.8 activate

Router-PE2(config-router-af)#end

Router-PE2#

注释 这里仍然不是全部的配置。对于BGP来说就不需要再配置再分布了,不过很少有运营商会支持客户网络的BGP互联

26.9. MPLS上的QoS

提问 配置MPLS上QoS的支持

回答

Router-PE1#configure terminal

Router-PE1(config)#class-map match-any med-priority

Router-PE1(config-cmap)#match precedence 1

Router-PE1(config-cmap)#match precedence 2

Router-PE1(config-cmap)#exit

Router-PE1(config)#class-map match-any high-priority

Router-PE1(config-cmap)#match precedence 3

Router-PE1(config-cmap)#match precedence 4

Router-PE1(config-cmap)#match precedence 5

Router-PE1(config-cmap)#exit

Router-PE1(config)#class-map match-any realtime-priority

Router-PE1(config-cmap)#match precedence 6

Router-PE1(config-cmap)#match dscp ef

Router-PE1(config-cmap)#exit

Router-PE1(config)#policy-map MPLS-priority

Router-PE1(config-pmap)#class realtime-priority

Router-PE1(config-pmap-c)#priority percent 10

Router-PE1(config-pmap-c)#set mpls experimental topmost 3

Router-PE1(config-pmap-c)#exit

Router-PE1(config-pmap)#class high-priority

Router-PE1(config-pmap-c)#bandwidth percent 10

Router-PE1(config-pmap-c)#queue-limit 20

Router-PE1(config-pmap-c)#set mpls experimental topmost 2

Router-PE1(config-pmap-c)#exit

Router-PE1(config-pmap)#class med-priority

Router-PE1(config-pmap-c)#bandwidth percent 15

Router-PE1(config-pmap-c)#queue-limit 50

Router-PE1(config-pmap-c)#set mpls experimental topmost 1

Router-PE1(config-pmap-c)#exit

Router-PE1(config-pmap)#class class-default

Router-PE1(config-pmap-c)#bandwidth percent 40

Router-PE1(config-pmap-c)#random-detect

Router-PE1(config-pmap-c)#set mpls experimental topmost 0

Router-PE1(config-pmap-c)#exit

Router-PE1(config-pmap)#exit

Router-PE1(config)#interface Serial0/0

Router-PE1(config-if)#service-policy output MPLS-priority

Router-PE1(config-if)#exit

Router-PE1(config)#end

Router-PE1#

Router-P1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-P1(config)#class-map match-any med-priority

Router-P1(config-cmap)#match mpls experimental topmost 1

Router-P1(config-cmap)#exit

Router-P1(config)#class-map match-any high-priority

Router-P1(config-cmap)#match mpls experimental topmost 2

Router-P1(config-cmap)#exit

Router-P1(config)#class-map match-any realtime-priority

Router-P1(config-cmap)#match mpls experimental topmost 3

Router-P1(config-cmap)#exit

Router-P1(config)#policy-map MPLS-priority

Router-P1(config-pmap)#class realtime-priority

Router-P1(config-pmap-c)#priority percent 10

Router-P1(config-pmap-c)#exit

Router-P1(config-pmap)#class high-priority

Router-P1(config-pmap-c)#bandwidth percent 10

Router-P1(config-pmap-c)#queue-limit 20

Router-P1(config-pmap-c)#exit

Router-P1(config-pmap)#class med-priority

Router-P1(config-pmap-c)#bandwidth percent 15

Router-P1(config-pmap-c)#queue-limit 50

Router-P1(config-pmap-c)#exit

Router-P1(config-pmap)#class class-default

Router-P1(config-pmap-c)#bandwidth percent 40

Router-P1(config-pmap-c)#random-detect

Router-P1(config-pmap-c)#exit

Router-P1(config-pmap)#exit

Router-P1(config)#interface FastEthernet0/0

Router-P1(config-if)#service-policy output MPLS-priority

Router-P1(config-if)#exit

Router-P1(config)#end

Router-P1#

注释 简单的说就是PE做客户网络数据包的DSCP或者IP优先级位和MPLS EXP优先级位之间的转化,EXP目前只能支持四种类型的数据包。很有用的验证命令

Router-P1#show policy interface FastEthernet0/0

FastEthernet0/0

Service-policy output: MPLS-priority

Class-map: realtime-priority (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: mpls experimental topmost 3

0 packets, 0 bytes

5 minute rate 0 bps

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 10 (%)

Bandwidth 10000 (kbps) Burst 250000 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

进入讨论组讨论。

26.10. Autoroute 和MPLS流量工程

提问 使用autoroute特性来自动维护MPLS网络的流量工程路径

回答

Router-PE1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE1(config)#mpls traffic-eng tunnels

Router-PE1(config)#interface Loopback0

Router-PE1(config-if)#ip address 10.0.0.2 255.255.255.255

Router-PE1(config-if)#exit

Router-PE1(config)#interface Tunnel11

Router-PE1(config-if)#ip unnumbered Loopback0

Router-PE1(config-if)#tunnel destination 10.0.0.3

Router-PE1(config-if)#tunnel mode mpls traffic-eng

Router-PE1(config-if)#tunnel mpls traffic-eng autoroute announce

Router-PE1(config-if)#tunnel mpls traffic-eng priority 7 7

Router-PE1(config-if)#tunnel mpls traffic-eng bandwidth 256

Router-PE1(config-if)#tunnel mpls traffic-eng path-option 1 explicit name def-PE3

Router-PE1(config-if)#exit

Router-PE1(config)#interface Tunnel12

Router-PE1(config-if)#ip unnumbered Loopback0

Router-PE1(config-if)#tunnel destination 10.0.0.3

Router-PE1(config-if)#tunnel mode mpls traffic-eng

Router-PE1(config-if)#tunnel mpls traffic-eng autoroute announce

Router-PE1(config-if)#tunnel mpls traffic-eng priority 7 7

Router-PE1(config-if)#tunnel mpls traffic-eng bandwidth 256

Router-PE1(config-if)#tunnel mpls traffic-eng path-option 1 explicit name hi-PE3

Router-PE1(config-if)#exit

Router-PE1(config)#interface Serial0/0

Router-PE1(config-if)#ip address 10.1.1.13 255.255.255.252

Router-PE1(config-if)#mpls traffic-eng tunnels

Router-PE1(config-if)#tag-switching ip

Router-PE1(config-if)#ip rsvp bandwidth 512

Router-PE1(config-if)#exit

Router-PE1(config)#interface ATM1/0.1 tag-switching

Router-PE1(config-subif)#ip address 10.1.1.2 255.255.255.252

Router-PE1(config-subif)#mpls traffic-eng tunnels

Router-PE1(config-subif)#tag-switching ip

Router-PE1(config-subif)#ip rsvp bandwidth 4000

Router-PE1(config-subif)#exit

Router-PE1(config)#router ospf 99

Router-PE1(config-router)#router-id 10.0.0.2

Router-PE1(config-router)#log-adjacency-changes

Router-PE1(config-router)#network 10.0.0.0 0.255.255.255 area 0

Router-PE1(config-router)#mpls traffic-eng router-id Loopback0

Router-PE1(config-router)#mpls traffic-eng area 0

Router-PE1(config-router)#exit

Router-PE1(config)#ip explicit-path name def-PE3 enable

Router-PE1(cfg-ip-expl-path)#next-address 10.1.1.14

Explicit Path name def-PE3:

1: next-address 10.1.1.14

Router-PE1(cfg-ip-expl-path)#next-address 10.1.1.9

Explicit Path name def-PE3:

1: next-address 10.1.1.14

2: next-address 10.1.1.9

Router-PE1(cfg-ip-expl-path)#exit

Router-PE1(config)#ip explicit-path name hi-PE3 enable

Router-PE1(cfg-ip-expl-path)#next-address 10.1.1.1

Explicit Path name hi-PE3:

1: next-address 10.1.1.1

Router-PE1(cfg-ip-expl-path)#next-address 10.1.1.6

Explicit Path name hi-PE3:

1: next-address 10.1.1.1

2: next-address 10.1.1.6

Router-PE1(cfg-ip-expl-path)#exit

Router-PE1(config)#end

Router-PE1#

Router-PE3#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE3(config)#mpls traffic-eng tunnels

Router-PE3(config)#interface Loopback0

Router-PE3(config-if)#ip address 10.0.0.3 255.255.255.255

Router-PE3(config-if)#exit

Router-PE3(config)#interface Tunnel11

Router-PE3(config-if)#ip unnumbered Loopback0

Router-PE3(config-if)#tunnel destination 10.0.0.2

Router-PE3(config-if)#tunnel mode mpls traffic-eng

Router-PE3(config-if)#tunnel mpls traffic-eng autoroute announce

Router-PE3(config-if)#tunnel mpls traffic-eng priority 7 7

Router-PE3(config-if)#tunnel mpls traffic-eng bandwidth 256

Router-PE3(config-if)#tunnel mpls traffic-eng path-option 1 explicit name def-PE1

Router-PE3(config-if)#exit

Router-PE3(config)#interface Tunnel12

Router-PE3(config-if)#ip unnumbered Loopback0

Router-PE3(config-if)#tunnel destination 10.0.0.2

Router-PE3(config-if)#tunnel mode mpls traffic-eng

Router-PE3(config-if)#tunnel mpls traffic-eng autoroute announce

Router-PE3(config-if)#tunnel mpls traffic-eng priority 7 7

Router-PE3(config-if)#tunnel mpls traffic-eng bandwidth 256

Router-PE3(config-if)#tunnel mpls traffic-eng path-option 1 explicit name hi-PE1

Router-PE3(config-if)#exit

Router-PE3(config)#interface Serial0/0

Router-PE3(config-if)#ip address 10.1.1.9 255.255.255.252

Router-PE3(config-if)#mpls traffic-eng tunnels

Router-PE3(config-if)#tag-switching ip

Router-PE3(config-if)#ip rsvp bandwidth 512

Router-PE3(config-if)#exit

Router-PE3(config)#interface ATM1/0.1 tag-switching

Router-PE3(config-subif)#ip address 10.1.1.6 255.255.255.252

Router-PE3(config-subif)#mpls traffic-eng tunnels

Router-PE3(config-subif)#tag-switching ip

Router-PE3(config-subif)#ip rsvp bandwidth 4000

Router-PE3(config-subif)#exit

Router-PE3(config)#router ospf 99

Router-PE3(config-router)#router-id 10.0.0.3

Router-PE3(config-router)#log-adjacency-changes

Router-PE3(config-router)#network 10.0.0.0 0.255.255.255 area 0

Router-PE3(config-router)#mpls traffic-eng router-id Loopback0

Router-PE3(config-router)#mpls traffic-eng area 0

Router-PE3(config-router)#exit

Router-PE3(config)#ip explicit-path name def-PE1 enable

Router-PE3(cfg-ip-expl-path)#next-address 10.1.1.10

Explicit Path name def-PE1:

1: next-address 10.1.1.10

Router-PE3(cfg-ip-expl-path)#next-address 10.1.1.13

Explicit Path name def-PE1:

1: next-address 10.1.1.10

2: next-address 10.1.1.13

Router-PE3(cfg-ip-expl-path)#exit

Router-PE3(config)#ip explicit-path name hi-PE1 enable

Router-PE3(cfg-ip-expl-path)#next-address 10.1.1.5

Explicit Path name hi-PE1:

1: next-address 10.1.1.5

Router-PE3(cfg-ip-expl-path)#next-address 10.1.1.2

Explicit Path name hi-PE1:

1: next-address 10.1.1.5

2: next-address 10.1.1.2

Router-PE3(cfg-ip-expl-path)#exit

Router-PE3(config)#end

Router-PE3#

Router-P1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-P1(config)#mpls traffic-eng tunnels

Router-P1(config)#interface Loopback0

Router-P1(config-if)#ip address 10.0.0.11 255.255.255.255

Router-P1(config-if)#exit

Router-P1(config)#interface Serial0/0

Router-P1(config-if)#ip address 10.1.1.14 255.255.255.252

Router-P1(config-if)#tag-switching ip

Router-P1(config-if)#mpls traffic-eng tunnels

Router-P1(config-if)#ip rsvp bandwidth 512

Router-P1(config-if)#exit

Router-P1(config)#interface Serial0/1

Router-P1(config-if)#ip address 10.1.1.10 255.255.255.252

Router-P1(config-if)#tag-switching ip

Router-P1(config-if)#mpls traffic-eng tunnels

Router-P1(config-if)#ip rsvp bandwidth 512

Router-P1(config-if)#exit

Router-P1(config)#router ospf 99

Router-P1(config-router)#router-id 10.0.0.11

Router-P1(config-router)#log-adjacency-changes

Router-P1(config-router)#network 10.0.0.0 0.255.255.255 area 0

Router-P1(config-router)#mpls traffic-eng router-id Loopback0

Router-P1(config-router)#mpls traffic-eng area 0

Router-P1(config-router)#exit

Router-P1(config)#end

Router-P1#

注释 很复杂啊,还没很明白

进入讨论组讨论。

26.11. MPLS上的组播

提问 配置MPLS网络对客户组播的支持

回答

Router-C-An#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-C-An(config)#ip multicast-routing

Router-C-An(config)#interface FastEthernet0/0

Router-C-An(config-if)#ip address 192.168.5.12 255.255.255.0

Router-C-An(config-if)#ip pim sparse-dense-mode

Router-C-An(config-if)#exit

Router-C-An(config)#end

Router-C-An#

Router-CE-A1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A1(config)#ip multicast-routing

Router-CE-A1(config)#interface FastEthernet0/0.1

Router-CE-A1(config-subif)#encapsulation dot1Q 101

Router-CE-A1(config-subif)#ip address 192.168.1.5 255.255.255.0

Router-CE-A1(config-subif)#ip pim sparse-dense-mode

Router-CE-A1(config-subif)#exit

Router-CE-A1(config)#interface FastEthernet0/0.2

Router-CE-A1(config-subif)#encapsulation dot1Q 111

Router-CE-A1(config-subif)#ip address 192.168.5.1 255.255.255.0

Router-CE-A1(config-subif)#ip pim sparse-dense-mode

Router-CE-A1(config-subif)#exit

Router-CE-A1(config)#end

Router-CE-A1#

Router-CE-A2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A2(config)#ip multicast-routing

Router-CE-A2(config)#interface Loopback0

Router-CE-A2(config-if)#ip address 10.8.8.8 255.255.255.255

Router-CE-A2(config-if)#ip pim sparse-dense-mode

Router-CE-A2(config-if)#ip igmp join-group 239.1.1.1

Router-CE-A2(config-if)#exit

Router-CE-A2(config)#interface Ethernet0

Router-CE-A2(config-if)#ip address 192.168.3.8 255.255.255.0

Router-CE-A2(config-if)#ip pim sparse-dense-mode

Router-CE-A2(config-if)#exit

Router-CE-A2(config)#end

Router-CE-A2#

Router-PE1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE1(config)#ip multicast-routing

Router-PE1(config)#interface Loopback0

Router-PE1(config-if)#ip address 10.0.0.2 255.255.255.255

Router-PE1(config-if)#ip pim sparse-dense-mode

Router-PE1(config-if)#exit

Router-PE1(config)#interface Serial0/0

Router-PE1(config-if)#ip address 10.1.1.13 255.255.255.252

Router-PE1(config-if)#ip pim sparse-dense-mode

Router-PE1(config-if)#tag-switching ip

Router-PE1(config-if)#exit

Router-PE1(config)#ip multicast-routing vrf NetworkA

Router-PE1(config)#ip vrf NetworkA

Router-PE1(config-vrf)#rd 100:1

Router-PE1(config-vrf)#route-target export 100:1

Router-PE1(config-vrf)#route-target import 100:1

Router-PE1(config-vrf)#mdt default 239.100.100.1

Router-PE1(config-vrf)#exit

Router-PE1(config)#interface Loopback155

Router-PE1(config-if)#ip vrf forwarding NetworkA

Router-PE1(config-if)#ip address 192.168.155.1 255.255.255.255

Router-PE1(config-if)#ip pim sparse-dense-mode

Router-PE1(config-if)#exit

Router-PE1(config)#interface Ethernet0/0

Router-PE1(config-if)#description connection to customer A, site 1

Router-PE1(config-if)#ip vrf forwarding NetworkA

Router-PE1(config-if)#ip address 192.168.1.1 255.255.255.0

Router-PE1(config-if)#ip pim sparse-dense-mode

Router-PE1(config-if)#exit

Router-PE1(config)#ip pim vrf NetworkA send-rp-announce Loopback155 scope 15

Router-PE1(config)#ip pim vrf NetworkA send-rp-discovery Loopback155 scope 15

Router-PE1(config)#end

Router-PE1#

Router-PE2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-PE2(config)#ip multicast-routing

Router-PE2(config)#interface Loopback0

Router-PE2(config-if)#ip address 10.0.0.4 255.255.255.255

Router-PE2(config-if)#ip pim sparse-dense-mode

Router-PE2(config-if)#exit

Router-PE2(config)#interface FastEthernet0/0.1

Router-PE2(config-subif)#encapsulation dot1Q 10

Router-PE2(config-subif)#ip address 10.1.2.4 255.255.255.0

Router-PE2(config-subif)#ip pim sparse-dense-mode

Router-PE2(config-subif)#tag-switching ip

Router-PE2(config-subif)#exit

Router-PE2(config)#ip multicast-routing vrf NetworkA

Router-PE2(config)#ip vrf NetworkA

Router-PE2(config-vrf)#rd 100:1

Router-PE2(config-vrf)#route-target export 100:1

Router-PE2(config-vrf)#route-target import 100:1

Router-PE2(config-vrf)#mdt default 239.100.100.1

Router-PE2(config-vrf)#exit

Router-PE2(config)#interface Loopback155

Router-PE2(config-if)#ip vrf forwarding NetworkA

Router-PE2(config-if)#ip address 192.168.155.2 255.255.255.255

Router-PE2(config-if)#ip pim sparse-dense-mode

Router-PE2(config-if)#exit

Router-PE2(config)#interface FastEthernet0/0.2

Router-PE2(config-subif)#encapsulation dot1Q 102

Router-PE2(config-subif)#ip vrf forwarding NetworkA

Router-PE2(config-subif)#ip address 192.168.3.1 255.255.255.0

Router-PE2(config-subif)#ip pim sparse-dense-mode

Router-PE2(config-subif)#exit

Router-PE2(config)#end

Router-PE2#

Router-P1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-P1(config)#ip multicast-routing

Router-P1(config)#interface FastEthernet0/0

Router-P1(config-if)#ip address 10.1.2.11 255.255.255.0

Router-P1(config-if)#ip pim sparse-dense-mode

Router-P1(config-if)#tag-switching ip

Router-P1(config-if)#exit

Router-P1(config)#interface Serial0/0

Router-P1(config-if)#ip address 10.1.1.14 255.255.255.252

Router-P1(config-if)#ip pim sparse-dense-mode

Router-P1(config-if)#tag-switching ip

Router-P1(config-if)#exit

Router-P1(config)#interface Serial0/1

Router-P1(config-if)#ip address 10.1.1.10 255.255.255.252

Router-P1(config-if)#ip pim sparse-dense-mode

Router-P1(config-if)#tag-switching ip

Router-P1(config-if)#exit

Router-P1(config)#end

Router-P1#

注释 无

进入讨论组讨论。

26.12. 服务商不能我能

提问 通过其他方式来实现运营商所不能提供的特性

回答

Router-CE-A1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A1(config)#ip multicast-routing

Router-CE-A1(config)#interface FastEthernet0/0.1

Router-CE-A1(config-if)#encapsulation dot1Q 101

Router-CE-A1(config-if)#ip address 192.168.1.5 255.255.255.0

Router-CE-A1(config-if)#exit

Router-CE-A1(config)#interface Loopback1

Router-CE-A1(config-if)#ip address 192.168.101.1 255.255.255.255

Router-CE-A1(config-if)#exit

Router-CE-A1(config)#interface Tunnel1

Router-CE-A1(config-if)#ip address 192.168.152.1 255.255.255.252

Router-CE-A1(config-if)#tunnel source 192.168.101.1

Router-CE-A1(config-if)#tunnel destination 192.168.101.2

Router-CE-A1(config-if)#ip pim sparse-dense-mode

Router-CE-A1(config-if)#exit

Router-CE-A1(config)#router bgp 65535

Router-CE-A1(config-router)#neighbor 192.168.1.1 remote-as 100

Router-CE-A1(config-router)#network 192.168.1.0

Router-CE-A1(config-router)#network 192.168.101.1 mask 255.255.255.255

Router-CE-A1(config-router)#no synchronization

Router-CE-A1(config-router)#no auto-summary

Router-CE-A1(config-router)#exit

Router-CE-A1(config)#router ospf 155

Router-CE-A1(config-router)#network 192.168.5.0 0.0.0.255 area 0

Router-CE-A1(config-router)#network 192.168.152.0 0.0.0.255 area 0

Router-CE-A1(config-router)#exit

Router-CE-A1(config)#end

Router-CE-A1#

Router-CE-A2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router-CE-A2(config)#ip multicast-routing

Router-CE-A2(config)#interface Ethernet0

Router-CE-A2(config-if)#ip address 192.168.3.8 255.255.255.0

Router-CE-A2(config-if)#exit

Router-CE-A2(config)#interface Loopback1

Router-CE-A2(config-if)#ip address 192.168.101.2 255.255.255.255

Router-CE-A2(config-if)#exit

Router-CE-A2(config)#interface Tunnel1

Router-CE-A2(config-if)#ip address 192.168.152.2 255.255.255.252

Router-CE-A2(config-if)#tunnel source 192.168.101.2

Router-CE-A2(config-if)#tunnel destination 192.168.101.1

Router-CE-A2(config-if)#ip pim sparse-dense-mode

Router-CE-A2(config-if)#exit

Router-CE-A2(config)#router bgp 65534

Router-CE-A2(config-router)#neighbor 192.168.3.1 remote-as 100

Router-CE-A2(config-router)#network 192.168.3.0

Router-CE-A2(config-router)#network 192.168.101.2 mask 255.255.255.0

Router-CE-A2(config-router)#no synchronization

Router-CE-A2(config-router)#no auto-summary

Router-CE-A2(config-router)#exit

Router-CE-A2(config)#router ospf 155

Router-CE-A2(config-router)#network 10.8.8.0 0.0.0.255 area 0

Router-CE-A2(config-router)#network 192.168.152.0 0.0.0.255 area 0

Router-CE-A2(config-router)#exit

Router-CE-A2(config)#end

Router-CE-A2#

注释 这里只是CE的配置,PE配置参考26.8。这里在服务商只支持BGP互联的网络中实现了OSPF和组播的传递

 
 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
2023年上半年GDP全球前十五强
 百态   2023-10-24
美众议院议长启动对拜登的弹劾调查
 百态   2023-09-13
上海、济南、武汉等多地出现不明坠落物
 探索   2023-09-06
印度或要将国名改为“巴拉特”
 百态   2023-09-06
男子为女友送行,买票不登机被捕
 百态   2023-08-20
手机地震预警功能怎么开?
 干货   2023-08-06
女子4年卖2套房花700多万做美容:不但没变美脸,面部还出现变形
 百态   2023-08-04
住户一楼被水淹 还冲来8头猪
 百态   2023-07-31
女子体内爬出大量瓜子状活虫
 百态   2023-07-25
地球连续35年收到神秘规律性信号,网友:不要回答!
 探索   2023-07-21
全球镓价格本周大涨27%
 探索   2023-07-09
钱都流向了那些不缺钱的人,苦都留给了能吃苦的人
 探索   2023-07-02
倩女手游刀客魅者强控制(强混乱强眩晕强睡眠)和对应控制抗性的关系
 百态   2020-08-20
美国5月9日最新疫情:美国确诊人数突破131万
 百态   2020-05-09
荷兰政府宣布将集体辞职
 干货   2020-04-30
倩女幽魂手游师徒任务情义春秋猜成语答案逍遥观:鹏程万里
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案神机营:射石饮羽
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案昆仑山:拔刀相助
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案天工阁:鬼斧神工
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案丝路古道:单枪匹马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:与虎谋皮
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:李代桃僵
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:指鹿为马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:小鸟依人
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:千金买邻
 干货   2019-11-12
 
推荐阅读
 
 
 
>>返回首頁<<
 
靜靜地坐在廢墟上,四周的荒凉一望無際,忽然覺得,淒涼也很美
© 2005- 王朝網路 版權所有