!
vpdn enable
no vpdn logging
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
interface FastEthernet0
ip address 192.168.0.1 255.255.255.0
ip nat inside
!
interface ATM0/0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in
interface ATM0/0.1 point-to-point
pvc 8/81
pppoe-client dial-pool-number 1
!
interface Dialer1
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent vip pass vip
ip nat inside source list 1 interface Dialer1 overload
!
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
Access-list 1 permit 192.168.0.0 0.0.0.255
ADSL上网完全可以不用ATM模块,用2514+IOS12.2就行了,
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service passWord-encryption
!
hostname 2621
!
enable secret 5 $1$LJV3$jqSDKFMSZiQBAjlnN/
!
ip subnet-zero
ip name-server 202.xxx.xxx.xxx
!
vpdn enable
!
vpdn-group PPPoE
request-dialin
protocol pppoe
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
speed 10
half-duplex
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username abc123@163 password 7 **********
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
no ip http server
ip pim bidir-enable
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
password *****
login
!
end