==================
LDP CONFIGURATION
=================
conf t
mpls label protocol ldp
ip cef
int
mpls ip
LDP Verification
show mpls interface
show mpls ldp discovery
debug mpls ldp session state-machine
=================================
TRAFFIC ENGINEERING CONFIGURATION
=================================
conf t
mpls traffic-eng tunnels
ip cef
int
mpls traffic-eng tunnels
ip rsvp bandwidth 1000
*Dynamic* tunnel config
interface Tunnel X
ip unnumbered loopback0
tunnel destination
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng path-option 1 dynamic
description
*Static* tunnel config
interface Tunnel 6
ip unnumbered loopback0
tunnel destination
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 eXPlicit name team6exp
From the Router global config, specify the path for the explicit tunnel
ip explicit-path name team6exp enable
next-address 132.0.0.1
next-address 134.0.0.1
next-address 133.0.0.1
next-address 130.0.0.1
Tunnel Status Verification
Ping tunnel destination address to verify the tunnel is up
Head end - show int tunnel X accounting
Midpoint - show mpls forwarding-table
Both - show mpls traffic-eng tunnels brief
show mpls traffic topology path tunnel X
=================
QoS CONFIGURATION
=================
Create a Traffic Class
class-map match-any Router X
match protocol ip
Create a Traffic Policy
policy-map RxPolice
class Router X
police 72000 20000 80000 conform-action set-prec-transmit 2 exceed-action set-prec-transmit 1
Attach Traffic Policy to an Interface
service-policy input RxPolice
service-policy output RxPolice
QoS Verification
show policy-map interface Serial0/x input/output
...
=================
VPN CONFIGURATION
=================
PE-PE Routing
conf t
router bgp 100
no bgp default ipv4-unicast
neighbor remote-as 100
neighbor active
address-family vpnv4
neighbor
neighbor
neighbor
neighbor send-community extended
neighbor send-community extended
neighbor send-community extended
PE-CE Routing
conf t
router bgp 100
address-family ipv4 vrf test1
neighbor remote-as
neighbor active
CE Routing
conf t
router bgp
neighbor remote-as 100
network mask
The IP Address to be used is the PE routers interface address.
The network is the loopback address and mask of the CE router
Configuring Interfaces (on PE routers only)
conf t
ip vrf test1
rd 100:1
route-target both 100:1
conf t
int Serial0/X
ip vrf forwarding test1
VPN debug
show mpls for vrf
show ip bgp vpnv4 all tags
show ip cef vrf detail
=================
MPLS of FR
=================
!
mpls label protocol ldp
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
!
interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface POS3/1
no ip address
encapsulation frame-relay
no keepalive
mls qos trust dscp
!
interface POS3/1.1 point-to-point
ip address 110.1.1.2 255.255.255.0
tag-switching ip
mls qos trust dscp
frame-relay interface-dlci 100
!
interface POS3/5
ip address 120.1.1.1 255.255.255.0
encapsulation ppp
no keepalive
tag-switching ip
mls qos trust dscp
!
router ospf 100
log-adjacency-changes
network 11.0.0.0 0.255.255.255 area 100
network 110.1.1.0 0.0.0.255 area 100
network 111.1.1.0 0.0.0.255 area 100
network 120.1.1.0 0.0.0.255 area 100
network 121.1.1.0 0.0.0.255 area 100
!
PE1#sh frame pvc 100
PVC Statistics for interface POS3/1 (Frame Relay DTE)
DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = POS3/1.1
input pkts 82 output pkts 1082 in bytes 6219
out bytes 110168 dropped pkts 0