前言
当您希望流出的模拟呼叫使用一条 特定的T1/E1 线路时,您能设置modem dialout controller 命令 。此命令设置在线性配置模式,因此调制解调器一定对指定 的T1/E1 接口为所有outbound 模拟呼叫。您能然后设定 neccessary 拨号请求路由选择(DDR) 命令在异步(或异步组) 接口 对应于调制解调器。
在此示例配置 Cisco AS5300 网络访问服务器(NAS) 有二PRIs ,其中每一被映射 到不同的Dialed Number Identification Service (DNIS) 。 假如客户端拨号8210 Telco 交换机呼叫对E1 0 和呼叫请求 8211 被交换对E1 1 。此配置也使用调制解调器汇集分配根 据索书号(DNIS) 消息的调制解调器提供由Telco 交换机在呼叫建 立期间。此方式要求一个特定号码是"answered"only 由是一 个特定调制解调器池的成员的调制解调器。因为每T1/E1 也 一定到一个特定的索书号,我们与特定的T1/E1 有效关联调制解调 器设置为流入的呼叫。
展示拨出方案 ,客户端请求回叫从访问服务器。回叫本地配置在访问服务 器但回呼属性可能从RADIUS/TACACS+ 认证、权限, 和审核(AAA) 服 务器也获得。对于一次流入的呼叫到一个特定号码,呼叫被 交换对适当的T1 并且由调制解调器池成员应答。在回叫协商 之后,访问服务器拆接呼叫并且回叫被起动在同样调制解调器。 拨出使用在modem dialout controller 命令指定的T1 或E1 接口然后 做。在本例中 ,配置拨出在T1/E1 和流入的呼叫一样。
在您开始之前
常 规
欲知详情关于文件协定的,查阅 Cisco 技术提示规定。
前提
此文件没有非凡的先决条件
组件使用了
本文的 信息根据以下的软件及硬件版本。
® Cisco IOS 软件发行12.1(5)T 。
Cisco AS5300 与二E1 PRIs 。
注重: modem dialout controller 命令被引入在12.1(T) 。 我们推荐IOS 版本12.1(3)T 或高为此实施。 modem dialout controller 命 令自12.1(5)T 支持多个接口。例如:
AS5300-3(config)#line 1 60
AS5300-3(config-line)#modem dialout controller t1 ?
List of controllers to dial out
AS5300-3(config-line)#modem dialout controller t1 0,1,3
当拨号从line/modem 1 至60 时,使用控制器T1 0 ,T1 1 ,T1 3 ,但没有其他。 modem dialout controller 命令 AS5xxx 平台只当前支持。
本文提供 的信息从设备被创建了在特定实验环境里。用于本文的所有 设备开始了以一个被清除(默认)配置。假如您工作在一个 真实网络,保证您使用它以前了解所有命令的潜在影响。
配置
在此部分,您出席以信息配置在本文描述的功能。
注重:找到附加 信息关于用于本文的命令,使用IOS 命令查找工具
网络图
本文使用网 络设置图示如下的。
配置
本文使用如下所示 的配置。
访问服务器配置
Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log uptime msec
no service passWord-encryption
!
hostname lala
!
logging rate-limit console 10 except errors
!
username testuser callback-dialstring 6036 password 0 test
!-- Access server calls back testuser at phone number 6036
!-- The callback parameters can also be configured on a RADIUS/TACACS+ server.
!
spe 1/0 1/9
firmware location system:/UCode/mica_port_firmware
spe 2/0 2/23
firmware location system:/ucode/microcom_firmware
!
resource-pool disable
!
modem-pool ModemPool8210
!-- Modem pool for calls to a specific phone number
pool-range 1-40
!-- The range of the modems in the pool
!-- Modems 1 through 40 are included in this pool
called-number 8210 max-conn 40
!-- Specifies the DNIS to be used for this modem pool
!-- Incoming calls for phone number 8210 are assigned to this
pool
!
modem-pool ModemPool8211
pool-range 41-60,61-84
!-- The range of the modems in the pool
!-- Modems 41 through 84 are included in this pool
called-number 8211 max-conn 44
!-- Incoming calls for phone number 8211 are assigned to this pool
!
ip subnet-zero
no ip finger
!
isdn switch-type primary-net5
chat-script mod ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 30 CONNECT \c
!-- Chat script for dialout
!
controller E1 0
!-- DNIS number for this E1 is 8210
clock source line primary
pri-group timeslots 1-31
!
controller E1 1
!-- DNIS number for this E1 is 8211
clock source line secondary 1
pri-group timeslots 1-31
!
controller E1 2
!
controller E1 3
!
!
interface Ethernet0
ip address 10.200.20.22 255.255.255.0
!
interface Serial0:15
!-- D-channel for E1 0
!-- DNIS number for this PRI is 8210
description PRI 8210
no ip address
encapsulation ppp
isdn switch-type primary-net5
isdn incoming-voice modem
!-- All incoming voice calls on this E1 are sent to the modems
!
interface Serial1:15
!-- D-channel for E1 1
!-- DNIS number for this PRI is 8211
description PRI 8211
no ip address
encapsulation ppp
isdn switch-type primary-net5
isdn incoming-voice modem
!-- All incoming voice calls on this E1 are sent to the modems
!
interface Group-Async1
ip unnumbered Ethernet0
encapsulation ppp
async mode interactive
peer default ip address pool dialup
!-- Assign IP address for incoming calls (with DNIS 8210) from pool dialup
ppp callback accept
!-- Permit PPP Callback
ppp authentication chap
group-range 1 40
!-- Interface includes modems 1 through 40 that are also in ModemPool8210
!
interface Group-Async2
ip unnumbered Ethernet0
encapsulation ppp
async mode interactive
peer default ip address pool dialup2
!-- Assign IP address for incoming calls (with DNIS 8211) from pool dialup2
ppp callback accept
!-- Here we accept the callback
ppp authentication chap
group-range 41 84
!-- Interface includes modems 41 through 84 that are also in ModemPool8211
!
ip local pool dialup 192.168.100.1 192.168.100.15
ip local pool dialup2 192.168.200.32 192.168.200.126
!-- Define the IP address ranges for the 2 pools
ip classless
no ip http server
!
line con 0
exec-timeout 0 0
transport input none
line 1 40
!-- Line configuration for modems 1-40
!-- These modems are in pool ModemPool8210
autoselect during-login
autoselect ppp
script callback mod
!-- Invoke chat script mod for the callback
login local
modem InOut
!-- Set the modems for dialin and dialout
modem dialout controller e1 0
!-- Outgoing call on these modems use e1 0
line 41 84
!-- Line configuration for modems 41-84
!-- These modems are in pool ModemPool8210
autoselect during-login
autoselect ppp
script callback mod
!-- Invoke chat script mod for the callback
login local
modem InOut
modem dialout controller e1 1
!-- Outgoing call on these modems use e1 1
line aux 0
line vty 0 4
!
end
验证
当前没有验证程序可用于此配置。
检修
此部分