1.After the router has reloaded. enter enable mode again.
Routerenable
Router#
2.Configure service timestamp to properly log and display debug output in the troubleshooting section.
Router#configure terminal
Router(config)#service timestamps debug datetime msec
Router(config)#service timestamps log datetime msec
Router(config)#end
3.Disable logging console on your Cisco DSL Router to suppress console messages that may be triggered while you are configuring the router.
Router#configure terminal
Router(config)#no logging console
Router(config)#end
4.Configure ip routing. ip subnet-zero. and ip classless to provide flexibility in routing configuration options.
Router#configure terminal
Router(config)#ip routing
Router(config)#ip subnet-zero
Router(config)#ip classless
Router(config)#end
5.Configure global Point-to-Point Protocol over Ethernet (PPPoE) parameters.
Router#configure terminal
Router(config)#vpdn enable
Router(config)#no vpdn logging
Router(config)#vpdn-group pppoe
Router(config-vpdn)#request-dialin
Router(config-vpdn-req-in)#protocol pppoe
Router(config-vpdn-req-in)#end
6.Configure an IP address and subnet mask on the Cisco DSL Router Ethernet interface.
(Optional) Enable NAT inside on the Ethernet interface.
Router#configure terminal
Router(config)#interface ethernet 0
Router(config-if)#ip tcp adjust-mss 1452/ip adjust-mss 1452
Router(config-if)#ip address 192.168.1.2 255.255.255.252
Router(config-if)#ip nat inside
Router(config-if)#no shut
Router(config-if)#end
7.Configure the ATM interface of your Cisco DSL Router with an ATM permanent virtual circuit (PVC). encapsulation type. and Dialer pool.
Router#configure terminal
Router(config)#interface atm 0
Router(config-if)#pvc 0/35 (Guizhou Province)
Router(config-if-atm-vc)#pppoe-client dial-pool-number 1
Router(config-if-atm-vc)#no shut
Router(config-if-atm-vc)#end
8.Configure the Dialer interface of your Cisco DSL Router for Point-to-Point Protocol over ATM (PPPoA) to enable a dynamic IP address to be assigned.
(Optional) Enable NAT outside on the Dialer interface.
Router#configure terminal
Router(config)#interface dialer 1
Router(config-if)#ip address negotiated
Router(config-if)#mtu 1492
Router(config-if)#no ip directed-broadcast
Router(config-if)#ip nat outside
Router(config-if)#encapsulation ppp
Router(config-if)#dialer pool 1
Router(config-if)#ppp auth chap hostname heiye
Router(config-if)#ppp auth chap passWord heiye
Router(config-if)#ppp auth pap sent-username heiye password heiye
Router(config-if)#end
9.Configure a default route using Dialer1 as the outbound interface.
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 dialer1
Router(config)#end
10.Configure global NAT commands on the Cisco DSL Router to allow sharing of the dynamic public IP address of the Dialer interface.
Router#configure terminal
Router(config)#ip nat inside source list 1 interface dialer1 overload
Router(config)#Access-list 1 permit 192.168.1.3 0.0.0.255
Router(config)#end
11.Optional Configurations
NAT Pool. if additional IP addresses have been provided by your ISP.
Router(config)#ip nat inside source list 1 pool ciscooverload
Router(config)#ip nat pool cisco 200.1.1. 200.1.1.254 netmask 255.255.255. 0
Router(config)#end
12.
Static NAT. if Internet users require access to internal servers.
Router(config)#ip nat inside source static tcp 192.168.1.5 80 200.1.1.5 80 extendable
Router(config)#end
13.(Optional) Configure the Cisco DSL Router as a DHCP server with a pool of IP addresses to assign to hosts connected to the Ethernet interface of the Cisco DSL Router. The DHCP server dynamically assigns an IP address. Domain Name Server (DNS). and the default gateway IP address to your hosts.
Router#configure terminal
Router(config)#ip dhcp excluded-address 192.168.21.2(E0 ip address)
Router(config)#ip dhcp pool wang
Router(dhcp-config)#network 192.168.1.2 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.2
Router(dhcp-config)#dns-server 202.98.198.168 202.98.192.68
Router(dhcp-config)#end
14.Enable the logging console on the Cisco DSL Router, and write all the changes to memory.
Router#configure terminal
Router(config)#logging console
Router(config)#end
*Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
Router#write memory/copy run start
Building configuration... [OK]
Router#show run
Router#show ip int brief
to view the IP interface status.