分享
 
 
 

CBAC配置教程例举

王朝other·作者佚名  2008-05-31
窄屏简体版  字體: |||超大  

2514 Router

version 11.3.3.T

!

no service tcp-small-servers

no service udp-small-servers

service passWord-encryption

no cdp running

no ip source-route

enable secret

!

!--- Here we have a syslog server.

!

logging 192.168.27.131

!

!--- This command enables the logging of session information (addresses and bytes).

!

ip inspect audit-trail

!

!--- Sets the length of time a TCP session is still managed after no activity.

!

ip inspect tcp idle-time 14400

!

!--- Sets the length of time a UDP session is still managed after no activity.

!

ip inspect udp idle-time 1800

!

!--- Sets the length of time a DNS name lookup session is still managed

!--- after no activity.

!

ip inspect dns-timeout 7

!

!--- Sets up inspection list "standard"

!--- to be used for inspection of inbound Ethernet 0

!--- and inbound serial (applied to both interfaces).

!

ip inspect name standard cuseeme

ip inspect name standard FTP

ip inspect name standard h323

ip inspect name standard http

ip inspect name standard rcmd

ip inspect name standard realaudio

ip inspect name standard smtp

ip inspect name standard sqlnet

ip inspect name standard streamworks

ip inspect name standard tcp

ip inspect name standard tftp

ip inspect name standard udp

ip inspect name standard vdolive

interface ethernet 0

ip address 192.168.27.129 255.255.255.128

!

!--- Apply access list to allow all legitimate traffic from inside network

!--- but PRevent spoofing.

!

ip access-group 101 in

!

!--- Apply an access list to allow some ICMP traffic; deny all else.

!--- The inspection list will add entries to this list to permit

!--- return traffic for connections established from inside.

!

ip access-group 102 out

!

!--- Apply inspection list "standard" for

!--- inspection of inbound Ethernet traffic.

!

ip inspect standard in

no ip directed-broadcast

no cdp enable

interface ethernet 1

ip address 192.168.27.1 255.255.255.128

!

!--- Apply the access list to permit DMZ traffic (except spoofing)

!--- DMZ interface inbound.

!

ip access-group 111 in

!

!--- Apply the access list to permit DNS, www, FTP, SMTP, POP3, Telnet

!--- to DMZ interface outbound.

!

!--- Inspection configured on other interfaces will add temporary entries

!--- to this list.

!

ip access-group 112 out

no ip directed-broadcast

no cdp enable

interface serial 0

ip address 200.200.200.1 255.255.255.0

!

!--- Apply the access list to prevent spoofing.

!

ip access-group 121 in

!

!--- Allow ping replies from inside or DMZ; permit inside traffic back out.

!--- Inspection will add temporary entries to this list.

!

ip access-group 122 out

!

!--- Apply inspection list "standard" for

!--- inspection of inbound serial traffic.

!

ip inspect standard in

no ip directed-broadcast

no cdp enable

!

!--- Access list 20 will be used to control which

!--- network management stations can access via SNMP.

!

access-list 20 permit 192.168.27.5

!

!--- We use an access list to allow all legitimate traffic from

!--- the inside network but prevent spoofing.

!

access-list 101 permit ip 192.168.27.128 0.0.0.127 any

access-list 101 deny ip any any

!

!--- Allow some ICMP traffic; deny all else.

!--- The inspection list will add entries to this list to permit

!--- return traffic for connections established from inside.

!

access-list 102 permit icmp any 192.168.27.128 0.0.0.127 administratively-prohibited

access-list 102 permit icmp any 192.168.27.128 0.0.0.127 echo

access-list 102 permit icmp any 192.168.27.128 0.0.0.127 echo-reply

access-list 102 permit icmp any 192.168.27.128 0.0.0.127 packet-too-big

access-list 102 permit icmp any 192.168.27.128 0.0.0.127 time-exceeded

access-list 102 permit icmp any 192.168.27.128 0.0.0.127 traceroute

access-list 102 permit icmp any 192.168.27.128 0.0.0.127 unreachable

access-list 102 deny ip any any

!

!

!--- The access list permits DMZ traffic (except spoofing)

!--- on DMZ interface inbound.

!

access-list 111 permit ip 192.168.27.0 0.0.0.127 any

access-list 111 deny ip any any

!

!

!--- This access list permits DNS, www, FTP, SMTP, POP3, Telnet to DMZ

!--- interface outbound. Inspection configured on other interfaces

!--- will add temporary entries to this list.

!

access-list 112 permit udp any host 192.168.27.3 eq domain

access-list 112 permit tcp any host 192.168.27.3 eq domain

access-list 112 permit tcp any host 192.168.27.3 eq www

access-list 112 permit tcp any host 192.168.27.3 eq ftp

access-list 112 permit tcp any host 192.168.27.3 eq smtp

access-list 112 permit tcp 192.168.27.128 0.0.0.127 host 192.168.27.3 eq pop3

access-list 112 permit tcp 192.168.27.128 0.0.0.127 any eq telnet

access-list 112 permit icmp any 192.168.27.0 0.0.0.127 administratively-prohibited

access-list 112 permit icmp any 192.168.27.0 0.0.0.127 echo

access-list 112 permit icmp any 192.168.27.0 0.0.0.127 echo-reply

access-list 112 permit icmp any 192.168.27.0 0.0.0.127 packet-too-big

access-list 112 permit icmp any 192.169.27.0 0.0.0.127 time-exceeded

access-list 112 permit icmp any 192.168.27.0 0.0.0.127 traceroute

access-list 112 permit icmp any 192.168.27.0 0.0.0.127 unreachable

access-list 112 deny ip any any

!

!--- Access list to prevent spoofing.

!

access-list 121 deny ip 192.168.27.0 0.0.0.255 any

access-list 121 deny ip 127.0.0.0 0.255.255.255 any

access-list 121 permit ip any any

!

!

!--- Access list for ping replies from inside or DMZ; permit inside traffic back out.

!--- Inspection will add temporary entries to this list.

!

access-list 122 permit icmp 192.168.27.0 0.0.0.255 any echo-reply

access-list 122 permit icmp 192.168.27.0 0.0.0.255 any time-exceeded

access-list 122 deny ip 192.168.27.0 0.0.0.127 any

access-list 122 permit ip 192.168.27.128 0.0.0.127 any

!

!--- Apply access list 20 for SNMP process.

!

snmp-server community secret RO 20

!

line con 0

exec-timeout 5 0

password 7 14191D1815023F2036

login local

line vty 0 4

exec-timeout 5 0

password 7 14191D1815023F2036

login local

length 35

end

 
 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
2023年上半年GDP全球前十五强
 百态   2023-10-24
美众议院议长启动对拜登的弹劾调查
 百态   2023-09-13
上海、济南、武汉等多地出现不明坠落物
 探索   2023-09-06
印度或要将国名改为“巴拉特”
 百态   2023-09-06
男子为女友送行,买票不登机被捕
 百态   2023-08-20
手机地震预警功能怎么开?
 干货   2023-08-06
女子4年卖2套房花700多万做美容:不但没变美脸,面部还出现变形
 百态   2023-08-04
住户一楼被水淹 还冲来8头猪
 百态   2023-07-31
女子体内爬出大量瓜子状活虫
 百态   2023-07-25
地球连续35年收到神秘规律性信号,网友:不要回答!
 探索   2023-07-21
全球镓价格本周大涨27%
 探索   2023-07-09
钱都流向了那些不缺钱的人,苦都留给了能吃苦的人
 探索   2023-07-02
倩女手游刀客魅者强控制(强混乱强眩晕强睡眠)和对应控制抗性的关系
 百态   2020-08-20
美国5月9日最新疫情:美国确诊人数突破131万
 百态   2020-05-09
荷兰政府宣布将集体辞职
 干货   2020-04-30
倩女幽魂手游师徒任务情义春秋猜成语答案逍遥观:鹏程万里
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案神机营:射石饮羽
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案昆仑山:拔刀相助
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案天工阁:鬼斧神工
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案丝路古道:单枪匹马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:与虎谋皮
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:李代桃僵
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:指鹿为马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:小鸟依人
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:千金买邻
 干货   2019-11-12
 
推荐阅读
 
 
 
>>返回首頁<<
 
靜靜地坐在廢墟上,四周的荒凉一望無際,忽然覺得,淒涼也很美
© 2005- 王朝網路 版權所有