!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname R-Shangxi
!
enable secret 5 $1$8dRf$zx3r9.B9KC29faWZvqSpc.
enable passWord cisco
!
username R-Zonghang password 7 xxxxx
username xxxxx password 7 xxxxx
username xxxxx password 7 xxxxx
username xxxxx password 7 xxxxx
username xxxxx password 7 xxxxx
username xxxxx password 7 xxxxx
username xxxxx password 7 xxxxx
username xxxxx password 7 xxxxx
ip subnet-zero
chat-script DDR "" "ATDT\T" TIMEOUT 60 "CONNECT"
!
interface Ethernet0
ip address 172.21.193.1 255.255.255.0
ip ospf network non-broadcast
!
interface Serial0
ip address 172.31.15.128 255.255.224.0
no ip mroute-cache
encapsulation x25
no ip route-cache
x25 address 12514
x25 htc 16
x25 win 7
x25 wout 7
x25 map ip 172.31.5.1 10414 broadcast compress
x25 map ip 172.31.22.192 14414 broadcast compress
x25 map ip 172.31.16.1 12614 broadcast compress
x25 map ip 172.31.21.128 13614 broadcast compress
x25 map ip 172.31.16.128 12814 broadcast compress
x25 map ip 172.31.17.1 12914 broadcast compress
x25 map ip 172.31.3.1 6727 broadcast compress
!
interface Serial1
no ip address
no ip mroute-cache
shutdown
!
interface Async1
ip unnumbered Dialer1
no ip mroute-cache
encapsulation ppp
no ip route-cache
keepalive 10
async dynamic routing
async mode interactive
peer default ip address 172.21.193.247
dialer in-band
dialer idle-timeout 100
dialer enable-timeout 2
dialer rotary-group 1
pulse-time 1
!
interface Async2
ip unnumbered Dialer1
no ip mroute-cache
encapsulation ppp
no ip route-cache
keepalive 10
shutdown
async dynamic routing
async mode interactive
peer default ip address 172.21.193.248
dialer in-band
dialer idle-timeout 100
dialer enable-timeout 2
dialer rotary-group 1
!
interface Async3
ip unnumbered Dialer1
no ip mroute-cache
encapsulation ppp
no ip route-cache
keepalive 10
shutdown
async dynamic routing
async mode interactive
peer default ip address 172.21.193.249
dialer in-band
dialer idle-timeout 100
dialer enable-timeout 2
dialer rotary-group 1
pulse-time 1
!
interface Async4
ip unnumbered Dialer1
no ip mroute-cache
encapsulation ppp
no ip route-cache
keepalive 10
shutdown
async dynamic routing
async mode interactive
peer default ip address 172.21.193.250
dialer in-band
dialer idle-timeout 100
dialer enable-timeout 2
dialer rotary-group 1
!
interface Async5
ip unnumbered Dialer1
no ip mroute-cache
encapsulation ppp
no ip route-cache
keepalive 10
async dynamic routing
async mode interactive
peer default ip address 172.21.193.251
dialer in-band
dialer idle-timeout 100
dialer enable-timeout 2
dialer rotary-group 1
!
interface Async6
no ip address
no ip mroute-cache
encapsulation ppp
keepalive 10
shutdown
async dynamic routing
async mode interactive
peer default ip address 172.21.193.252
dialer in-band
dialer idle-timeout 100
dialer enable-timeout 2
dialer rotary-group 1
pulse-time 1
!
interface Async7
no ip address
no ip mroute-cache
encapsulation ppp
keepalive 10
shutdown
async dynamic routing
async mode interactive
peer default ip address 172.21.193.253
dialer in-band
dialer idle-timeout 100
dialer enable-timeout 2
dialer rotary-group 1
pulse-time 1
!
interface Async8
no ip address
no ip mroute-cache
encapsulation ppp
keepalive 10
shutdown
async dynamic routing
async mode interactive
peer default ip address 172.21.193.254
dialer in-band
dialer idle-timeout 100
dialer enable-timeout 2
dialer rotary-group 1
!
interface Dialer1
ip address 172.31.76.128 255.255.224.0
no ip mroute-cache
encapsulation ppp
no ip route-cache
no keepalive
dialer in-band
dialer idle-timeout 100
dialer enable-timeout 2
dialer map ip 172.31.64.1 name R-Zonghang broadcast
dialer map ip 172.31.66.1 name R-Shanxi broadcast
dialer map ip 172.31.66.1 name R-Shanxi broadcast
dialer map ip 172.31.77.128 name R-Ningxia broadcast
dialer map ip 172.31.77.128 name R-Ningxia broadcast
dialer map ip 172.31.77.1 name R-Gansu broadcast
dialer map ip 172.31.78.1 name R-Xinjiang broadcast
dialer map ip 172.31.82.128 name R-xian broadcast
dialer map ip 172.31.82.128 name R-xian broadcast
dialer map ip 172.31.83.192 name R-Bingtuan broadcast
dialer map ip 172.31.83.192 name R-Bingtuan broadcast
dialer-group 1
ppp authentication chap
!
router ospf 1
redistribute bgp 26
network 172.21.193.0 0.0.0.255 area 0
!
router bgp 26
network 172.21.193.0 mask 255.255.255.0
aggregate-address 172.21.192.0 255.255.192.0 summary-only
redistribute ospf 1
neighbor 172.31.3.1 remote-as 1
neighbor 172.31.3.1 next-hop-self
neighbor 172.31.5.1 remote-as 5
neighbor 172.31.5.1 next-hop-self
neighbor 172.31.16.1 remote-as 27
neighbor 172.31.16.1 next-hop-self
neighbor 172.31.16.128 remote-as 28
neighbor 172.31.16.128 next-hop-self
neighbor 172.31.17.1 remote-as 29
neighbor 172.31.17.1 next-hop-self
neighbor 172.31.21.128 remote-as 45
neighbor 172.31.21.128 next-hop-self
neighbor 172.31.22.192 remote-as 47
neighbor 172.31.22.192 next-hop-self
!
ip classless
ip route 172.0.0.0 255.0.0.0 172.31.64.1 180
ip route 172.16.192.0 255.255.192.0 172.31.66.1 180
ip route 172.21.192.0 255.255.192.0 172.21.193.2 180
ip route 172.22.0.0 255.255.240.0 172.31.77.1 180
ip route 172.22.16.0 255.255.248.0 172.31.77.1 180
ip route 172.22.24.0 255.255.248.0 172.31.77.128 180
ip route 172.22.32.0 255.255.240.0 172.31.77.128 180
ip route 172.22.48.0 255.255.240.0 172.31.78.1 180
ip route 172.22.64.0 255.255.248.0 172.31.78.1 180
ip route 172.23.176.0 255.255.240.0 172.31.82.128 180
ip route 172.23.192.0 255.255.248.0 172.31.82.128 180
ip route 172.24.48.0 255.255.240.0 172.31.83.192 180
Access-list 101 deny ospf any any
access-list 101 deny tcp any any eq bgp
access-list 101 deny ip any host 255.255.255.255
access-list 101 deny ip host 255.255.255.255 any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
line con 0
line 1 8
no activation-character
script dialer DDR
modem InOut
autocommand ppp
transport input all
stopbits 1
rxspeed 38400
txspeed 38400
flowcontrol hardware
line aux 0
transport input all
line vty 0 4
password cisco
login