Question:
Let S = s1 s2 ¡ s2n be a well-formed string of parentheses. S can be encoded in two different ways:
By an integer sequence P = p1 p2 ¡ pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
By an integer sequence W = w1 w2 ¡ wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input:
The first line of the input contains a single integer t (1 ¡Ü t ¡Ü 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 ¡Ü n ¡Ü 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output:
The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input:
2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
Sample Output:
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
Solution:
// 声明:本代码仅供学习之用,请不要作为个人的成绩提交。
// email: skianet@yahoo.com.cn
#include <iostream>
using namespace std;
int main( void ) {
int cases;
cin >> cases;
for ( int i = 0 ; i < cases; ++i ) {
int n;
cin >> n;
char* par = new char[ n + n ];
int* pos = new int[ n ];
int lastc = 0 , c = 0 , count1 = 0;
for ( int j = 0; j < n; ++j ) {
cin >> c;
for ( int k = 0; k < c - lastc; ++k ) {
par[ count1 ] = '(';
++count1;
}
par[ count1 ] = ')';
pos[ j ] = count1;
++count1;
lastc = c;
}
for ( int j = 0; j < n; ++j ) {
if(j != 0) {
cout << " ";
}
int countleft = 0 , countright = 0;
for ( int k = pos[ j ]; k >= 0; --k ) {
switch ( par[ k ] ) {
case '(':
if ( ++countleft == countright ) {
cout << countright;
goto NEXTFORJ;
}
break;
case ')':
++countright;
break;
}
}
cout << countright;
NEXTFORJ:;
}
cout << endl;
delete[] par;
delete[] pos;
}
return 0;
}
[url=http://acm.zju.edu.cn/submit.php?pid=1016][/url]