All in All
You have devised a new encryption technique which encodes a message by inserting between its
characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can
remove characters from t such that the concatenation of the remaining characters is s.
Input SpecificationThe input contains several testcases. Each is specified by two strings s, t of alphanumeric
ASCII characters separated by whitespace. Input is terminated by EOF. Output SpecificationFor each test case output, if s is a subsequence of t. Sample Inputsequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample OutputYes
No
Yes
No
此代码速度一般但较易理解
#include<iostream>
#include<cstring>
using namespace std;
void main()
{
char s[100];
while(cin>>s)
{
int len=strlen(s);
char ch;
cin>>ch;
int idx=0;
while(ch!='\n')
{
if(ch==s[idx])
idx++;
cin.get(ch);
}
if(idx==len)
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
}