分享
 
 
 

acm.jlu.edu.cn-2005-The Dir Command

王朝other·作者佚名  2006-01-09
窄屏简体版  字體: |||超大  

The Dir Command

We all know the dos command "dir" . It can list the files in the computer . When we use the file

name with "?" , "*" as the parameter , it can list the files you need . Input SpecificationThere are several lines (at most 100) each contain a file name and terminated by a line containing '*' .

Then a line contains a integer N and followed N lines . Each line contain a command "dir" with parameter. Output SpecificationFor each "dir" print the result , each file name in a line in lower case . If nothing found print

"no such files" in a single line . Print a blank line after each result . Note that the command "dir" will

treat the capital letter and small letter as the same . Sample Inputautoexec.bat

boot.ini

bootfont.bin

config.sys

io.sys

msdos.sys

pagefile.sys

*

4

dir autoexec.bat

dir boot*.*

dir ??.sys

dir *.*

Sample Outputautoexec.bat

boot.ini

bootfont.bin

io.sys

autoexec.bat

boot.ini

bootfont.bin

config.sys

io.sys

msdos.sys

pagefile.sys

开始打算只用C的后来发现对输入的了解不够没办法了

#include<cstdio>

#include<iostream>

#include<cstring>

using namespace std;

void main()

{

char files[100][20];

int idx=0;

int idxf=0;

char ch;

scanf("%c",&ch);

while(ch!='*')

{

if(ch>='A'&&ch<='Z')

ch='a'+ch-'A';

files[idxf][idx++]=ch;

if(ch=='\n')

{

files[idxf][idx]='\0';

idx=0;

idxf++;

}

ch=getchar();

}

int n;

scanf("%d\n",&n);

for(int i=0;i<n;i++)

{

char com[20];//输入的命令保存在com

cin>>com;//滤掉dir

cin>>com;

for(int j=0;j<strlen(com);j++)

if(com[j]>='A'&&com[j]<='Z')

com[j]='a'+com[j]-'A';

bool found=false;

for(int j=0;j<idxf;j++)

{

int p=0,q=0;//p指向当前一个文件名中字字符,q指向命令中的字符

L1:if(files[j][p]==com[q])//字符相等,pass

{

p++;q++;

goto L1;

}

if(files[j][p]=='\n'&&strlen(com)==q)//两个字符串同时到头了,ok

{

printf("%s",files[j]);

found=true;

continue;

}

if(com[q]=='*')//'*'的匹配

{

if(com[q+1]=='\0')//如果*是命令的最后一个字符,ok

{

cout<<files[j];

found=true;

continue;

}

while(p<strlen(files[j])&&files[j][p]!=com[q+1])//匹配多个字符,直到有相同字符

p++;

q++;

goto L1;

}

if(files[j][p]!='\n'&&com[q]=='?')//匹配?,要保证文件名没到结束

{

p++;q++;

goto L1;

}

}

if(!found)

printf("no such files\n");

cout<<endl;

}

}

 
 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
2023年上半年GDP全球前十五强
 百态   2023-10-24
美众议院议长启动对拜登的弹劾调查
 百态   2023-09-13
上海、济南、武汉等多地出现不明坠落物
 探索   2023-09-06
印度或要将国名改为“巴拉特”
 百态   2023-09-06
男子为女友送行,买票不登机被捕
 百态   2023-08-20
手机地震预警功能怎么开?
 干货   2023-08-06
女子4年卖2套房花700多万做美容:不但没变美脸,面部还出现变形
 百态   2023-08-04
住户一楼被水淹 还冲来8头猪
 百态   2023-07-31
女子体内爬出大量瓜子状活虫
 百态   2023-07-25
地球连续35年收到神秘规律性信号,网友:不要回答!
 探索   2023-07-21
全球镓价格本周大涨27%
 探索   2023-07-09
钱都流向了那些不缺钱的人,苦都留给了能吃苦的人
 探索   2023-07-02
倩女手游刀客魅者强控制(强混乱强眩晕强睡眠)和对应控制抗性的关系
 百态   2020-08-20
美国5月9日最新疫情:美国确诊人数突破131万
 百态   2020-05-09
荷兰政府宣布将集体辞职
 干货   2020-04-30
倩女幽魂手游师徒任务情义春秋猜成语答案逍遥观:鹏程万里
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案神机营:射石饮羽
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案昆仑山:拔刀相助
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案天工阁:鬼斧神工
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案丝路古道:单枪匹马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:与虎谋皮
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:李代桃僵
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:指鹿为马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:小鸟依人
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:千金买邻
 干货   2019-11-12
 
推荐阅读
 
 
 
>>返回首頁<<
 
靜靜地坐在廢墟上,四周的荒凉一望無際,忽然覺得,淒涼也很美
© 2005- 王朝網路 版權所有