分享
 
 
 

acm.jlu.edu.cn-1068-Cipher

王朝other·作者佚名  2006-01-09
窄屏简体版  字體: |||超大  

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

InputThe input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

OutputOutput is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input10

4 5 3 7 2 8 1 6 10 9

1 Hello Bob

1995 CERC

0

0

Sample OutputBolHeol b

C RCE

#include<iostream>

#include<string>

#include<memory>

using namespace std;

const int N=201;

void main()

{

int key[N];//secret kay

int keys[N];//group information

char ct[N];//CipherText

bool used[N];

int cycle[N][N];

int n;

while(cin>>n,n>0)

{

for(int i=0;i<n;i++)

{

cin>>key[i];

}

memset(used,0,n*sizeof(bool));

int x=0;

int idxc=0;

while(x<n)

{

if(used[x])

{

x++;

continue;

}

else

{

used[x]=true;

int mark=x;

int len=1;

cycle[idxc][len]=key[x];

while(key[x]!=mark+1)

{

len++;

x=key[x]-1;

used[x]=true;

cycle[idxc][len]=key[x];

}

cycle[idxc][0]=len;

for(int i=1;i<=len;i++)

{

keys[cycle[idxc][i]-1]=idxc;

}

x=mark;

idxc++;

}

x++;

}

int m;

while(cin>>m,m>0)

{

char ch;

cin.get(ch);

int idx=0;

while(cin.get(ch),ch!='\n')

{

ct[idx++]=ch;

}

for(int i=idx;i<n;i++)

ct[i]=' ';

char it[N];//intertext;

memset(used,0,n*sizeof(bool));

x=0;

while(x<n)

{

if(used[x])

{

x++;

continue;

}

int mark=keys[x];

int step=m%cycle[mark][0];

int pi=1,pj=pi+step;

for(int i=0;i<cycle[mark][0];i++)

{

used[cycle[mark][pj]-1]=true;

it[cycle[mark][pj]-1]=ct[cycle[mark][pi]-1];

pi++;pj++;

if(pj==cycle[mark][0]+1)

pj=1;

}

x++;

}

it[n]='\0';

cout<<it<<endl;

}

cout<<endl;

}

}

 
 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
2023年上半年GDP全球前十五强
 百态   2023-10-24
美众议院议长启动对拜登的弹劾调查
 百态   2023-09-13
上海、济南、武汉等多地出现不明坠落物
 探索   2023-09-06
印度或要将国名改为“巴拉特”
 百态   2023-09-06
男子为女友送行,买票不登机被捕
 百态   2023-08-20
手机地震预警功能怎么开?
 干货   2023-08-06
女子4年卖2套房花700多万做美容:不但没变美脸,面部还出现变形
 百态   2023-08-04
住户一楼被水淹 还冲来8头猪
 百态   2023-07-31
女子体内爬出大量瓜子状活虫
 百态   2023-07-25
地球连续35年收到神秘规律性信号,网友:不要回答!
 探索   2023-07-21
全球镓价格本周大涨27%
 探索   2023-07-09
钱都流向了那些不缺钱的人,苦都留给了能吃苦的人
 探索   2023-07-02
倩女手游刀客魅者强控制(强混乱强眩晕强睡眠)和对应控制抗性的关系
 百态   2020-08-20
美国5月9日最新疫情:美国确诊人数突破131万
 百态   2020-05-09
荷兰政府宣布将集体辞职
 干货   2020-04-30
倩女幽魂手游师徒任务情义春秋猜成语答案逍遥观:鹏程万里
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案神机营:射石饮羽
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案昆仑山:拔刀相助
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案天工阁:鬼斧神工
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案丝路古道:单枪匹马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:与虎谋皮
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:李代桃僵
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:指鹿为马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:小鸟依人
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:千金买邻
 干货   2019-11-12
 
推荐阅读
 
 
 
>>返回首頁<<
 
靜靜地坐在廢墟上,四周的荒凉一望無際,忽然覺得,淒涼也很美
© 2005- 王朝網路 版權所有