URL: http://acm.zju.edu.cn/show_problem.php?pid=1089
Problem:
In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].
Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
Input Specification:
The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.
Output Specification
For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.
Sample Input:
7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0
Sample Output:
1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7
1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34
My solution: (C++, GCC)
It is a very good idea to solve this problem with six recirculating, if a speedy solution is needed. I implemented a simulator of number selector in the code below. Each time numbers are inputed, number selector will select six numbers from them, and output them in the same format as sample output. But in my opinion, due to the cost of iterations on function print_num, it will not have high efficiency when k becomes bigger and bigger. Fortunitely, k will never exceed thirteen in this problem.
#include <iostream>
#include <vector>
// PS: The code is for study purpose only, never submit it as ones own.
// From: http://blog.csdn.net/mskia/
// email: ichobits@21cn.com
std::vector<const int*> s;
void print_num(const int *begp, const int *endp, const int &level) {
if (level > 6) {
std::vector<const int*>::const_iterator p = s.begin();
std::cout << **p;
for (++p; p != s.end(); ++p) {
std::cout << ' ' << **p;
}
std::cout << std::endl;
return;
}
size_t interval = endp - begp + level - 5;
for (size_t i = 0; i < interval; ++i) {
s.push_back(begp + i);
print_num(begp + i + 1, endp, level + 1);
s.pop_back();
}
return;
}
int main(void) {
int num[13], c = 0;
int k;
while (std::cin >> k && k > 0) {
if (++c > 1) {
std::cout << std::endl;
}
for (int i = 0; i < k; ++i) {
std::cin >> num[i];
}
print_num(num, num + k - 1, 1);
}
return 0;
}