在IIS中部署Asp.Net网站

王朝学院·作者佚名  2016-08-28
窄屏简体版  字體: 小  |  中  |  大  |  超大  

1、权限问题

解决办法:更改网站权限,添加“IIS_IUsers”和“Users”两个用户的完全权限

2、framework版本问题

更改应用程序池 版本4.0,管道经典

3、“无法启动应用程序池”错误

打开服务,启动WindowsPRocess Activation Service服务

4、“无法启动网站”错误

打开服务,启动World Wide Web Publishing Service万维网发布服务

4、“请求的似乎是脚本”错误

window+r,输入cmd命令

输入cd C:\Windows\Microsoft.NET\Framework\v4.0.30319

输入aspnet_regiis -i

等待安装完成,打开整个服务器根目录,找到ISAPI和CGI限制,启动4.0的选项

即可

5、同一局域网内其他电脑可以访问关键点

防火墙,添加端口映射

 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
 
© 2005- 王朝網路 版權所有 導航