Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname client1
!
!
memory-size iomem 30
ip subnet-zero
!
!
!
!
!
interface Loopback0
ip address 11.1.1.1 255.0.0.0
no ip directed-broadcast
!
interface Ethernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Async65
no ip address
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer rotary-group 1
async mode dedicated
!
interface Dialer1
ip address negotiated
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer idle-timeout 3000
dialer string 3311
dialer-group 1
ppp callback request
ppp chap hostname client1
ppp chap password 7 030752180500
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
transport input none
line aux 0
modem InOut
transport input all
speed 38400
flowcontrol hardware
line vty 0 4
login
!
no scheduler allocate
end
--------------------------------------------------
server#sho run
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname server
!
username client1 callback-dialstring 3322 callback-rotary 1 password 0 cisco
chat-script offhook "" "ATH1" OK
chat-script test ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT
\c
!
interface Loopback0
ip address 10.1.1.1 255.0.0.0
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip unnumbered Loopback0
encapsulation ppp
async mode interactive
peer default ip address 10.1.1.2
ppp callback accept
ppp authentication chap
!
no ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.2
!
line con 0
line aux 0
autoselect ppp
script modem-off-hook offhook
script callback test
login local
modem InOut
modem autoconfigure discovery
rotary 1
transport input all
callback forced-wait 20
rxspeed 38400
txspeed 38400
line vty 0 4
login
!
end
----------------------------------------------------------------------------------------------
注:两边MODEM都设成自动应答。以上为路由器之间的回拨。
-----------------------------------------------------------------------------------
用WINDOWS拨路由器时IOS版本要高,(11.3以上),c2500-is-l.112-16.bin,2512-9p.bin不支持WINDOWS拨路由器,实验为c2600-is-mz.120_4.bin,路由器端配置不变。
,WINDOWS端按拨号网络配。WINDOWS端不设自动应答,路由器端不设自动应答。若需由
WINDOWS端指定回拨号码,则路由器端设
username client1 callback-dialstring "" callback-rotary 1 password 0 cisco即电话号码设为空。
chat-script test ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT中命令要大写。
2500系列的路由器一定要用chat-script,同时要在LINE中设script dialer或者在dialer map中用
modem-script命令。
****最重要的是:chat-script test "" "ATZ" TIMEOUT 30 OK "ATDT \T" TIMEOUT 30 CONNECT \c中CONNECT \c之间空格不能掉,
否则2501决对拨不上2611。千万要记住!!!
另外chat-script test中"ATZ"不能写成"AT",否则回拨PC端不应答或难应答。
最后一点:由2610中的2A/S卡异步拨中信NM-8AM模块时,chat-script test中"ATZ"不能写成"AT Z",同时使用
modem autoconfig discovery命令。NM-8AM模块端不用modem autoconfig discovery命令。