Router1-Client
router1#show running-config
Building configuration...
Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router1
!
username router2 password 0 snap
!-- Username for remote router (router2) and shared secret.
!-- Shared secret(used for CHAP) must be the same on both sides.
isdn switch-type basic-5ess
!
interface Loopback0
ip address 10.2.2.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.100.1 255.255.255.0
!
interface Serial0
no ip address
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 10.1.1.1 255.255.255.0
!-- IP address for the BRI interface.
encapsulation ppp
no keepalive
dialer idle-timeout 60
!-- Idle timeout(in seconds)for this BRI interface.
dialer map ip 10.1.1.2 name router2 broadcast 96666600
!-- This defines the ip address, router name, and dial string of the remote router.
! -- This will be used for normal DDR connections to the peer.
Dialer map snapshot 60 name router2 broadcast 96666600
!-- alternatively use: dialer map snapshot 60 96666600
!-- This specifies a sequence number of 60 to identify this dialer map and a dial
!-- string of 96666600 used to initiate a call during the snapshot active period.
!-- For more information about this command refer to the Command Summary section
!-- of this document
dialer hold-queue 10
dialer-group 1
!-- apply interesting traffic defined in dialer-list 1.
isdn switch-type basic-5ess
isdn T203 10000
snapshot client 5 30 suppress-statechange-update dialer
!-- This is a client side with an active period of 5 minutes and quiet period of
!-- 30 minutes. Routing table updates are not exchanged when other interesting
!-- traffic has activated the interface. This client is able initiate a call to
!-- start the active period for exchanging routing table updates. For more
!-- information about this command refer to the Command Summary section of this
!-- document
ppp authentication chap
!-- use chap authentication.
hold-queue 75 in
!
router igrp 100
network 10.0.0.0
network 192.168.100.0
!
ip classless
!
dialer-list 1 protocol ip permit
!-- Interesting traffic is defined by dialer-list 1.
!-- This is applied to BRI0 using dialer-group 1.
line con 0
line aux 0
line vty 0 4
login
!
end
Router2- Server
router2#show running-config
Building configuration...
Current configuration:
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router2
!
logging rate-limit console 10 except errors
!
username router1 password 0 snap
!-- Username for remote router (router1) and shared secret.
!-- Shared secret(used for CHAP) must be the same on both sides.
ip subnet-zero
no ip finger
!
no ip dhcp-client network-discovery
isdn switch-type basic-5ess
!
interface Loopback0
ip address 10.3.3.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.200.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 10.1.1.2 255.255.255.0
!-- IP address for the BRI interface.
Encapsulation ppp
no keepalive
dialer idle-timeout 60
!-- Idle timeout(in seconds)for this BRI interface.
Dialer map ip 10.1.1.1 name router1 broadcast 96666700
!-- Dialer map for the BRI interface of the remote router.
Dialer hold-queue 10
dialer-group 1
!-- Apply interesting traffic defined in dialer-list 1.
isdn switch-type basic-5ess
cdapi buffers regular 0
cdapi buffers raw 0
cdapi buffers large 0
snapshot server 5 dialer
!-- The snapshot server command specifies active period interval in minutes.
!-- The dialer parameter allows the router to make a DDR call to initiate a snapshot
!-- session in the absence of other "interesting" traffic initiating a DDR call.
!-- For more information about this command refer to the Command Summary section of
!-- this document.
ppp authentication chap
!-- Use CHAP authentication.
!
router igrp 100
network 10.0.0.0
network 192.168.200.0
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!-- Interesting traffic is defined by dialer-list 1.
!-- This is applied to BRI0 using dialer-group 1.
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end