分享
 
 
 

ACM and STL-DNA Sorting

王朝other·作者佚名  2006-01-31
窄屏简体版  字體: |||超大  

ACM and STL

DNA Sorting

Time Limit:1000MS Memory Limit:10000K

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6

AACATGAAGG

TTTTGGCCAA

TTTGGCCAAA

GATCAGATTT

CCCGGGGGGA

ATCGATGCAT

Sample Output

CCCGGGGGGA

AACATGAAGG

GATCAGATTT

ATCGATGCAT

TTTTGGCCAA

TTTGGCCAAA

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

//By LingCh

//2005-3-19

Analysis

This is a sort problem. As stated, we may first calculate the inversions of each string, and then sort the strings use their inversion as the sort key.

Source

Memory:88K Time:0MS

Language:C++ Result:Accepted

· #include<vector>

· #include<algorithm>

· #include<iostream>

·

· using namespace std;

·

· int n,m;

·

· class Mystring

· {

· public:

· int length;

· int inv;

· char str[50];

·

· Mystring()

· :length(0)

· ,inv(0)

· {

· str[0]=0;

· }

·

· Mystring& operator = (const Mystring& s);

·

· friend istream& operator >>(istream &is,Mystring &istr);

· friend ostream& operator <<(ostream &os,Mystring &ostr);

· };

·

· istream& operator >>(istream &is,Mystring &istr)

· {

· int i,j;

· istr.length=n;

· for(i=0;i<istr.length;i++)

· is>>istr.str[i];

· istr.str[istr.length]=0;

·

//here calculate the inversion of this string

· istr.inv=0;

· for(i=0;i<istr.length-1;i++)

· {

· for(j=i+1;j<istr.length;j++)

· {

· if(istr.str[i]>istr.str[j])

· istr.inv++;

· }

· }

· return is;

· }

·

· Mystring& Mystring::operator = (const Mystring& sr)

· {

· if (&sr != this)

· {

· copy(&sr.str[0],&sr.str[length],this->str);

· inv=sr.inv;

· length=sr.length;

· }

· return *this;

· }

·

· ostream& operator <<(ostream &os,Mystring &ostr)

· {

· int i;

· for(i=0;i<ostr.length;i++)

· os<<ostr.str[i];

· return os;

· }

·

· //this predicate use the inversion of the string as the sort key

· bool MyPre(Mystring s1,Mystring s2)

· {

· if(s1.inv<s2.inv)

· return true;

· else

· return false;

· }

·

· int main()

· {

· int i;

· cin>>n>>m;

·

· vector<Mystring> ss;

· for(i=0;i<m;i++)

· {

· Mystring s;

· cin>>s;

· ss.push_back(s);

· }

·

· sort(ss.begin(),ss.end(),MyPre);

·

· for(i=0;i<m;i++)

· cout<<ss[i]<<endl;

·

· //system("pause");

· }

 
 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
2023年上半年GDP全球前十五强
 百态   2023-10-24
美众议院议长启动对拜登的弹劾调查
 百态   2023-09-13
上海、济南、武汉等多地出现不明坠落物
 探索   2023-09-06
印度或要将国名改为“巴拉特”
 百态   2023-09-06
男子为女友送行,买票不登机被捕
 百态   2023-08-20
手机地震预警功能怎么开?
 干货   2023-08-06
女子4年卖2套房花700多万做美容:不但没变美脸,面部还出现变形
 百态   2023-08-04
住户一楼被水淹 还冲来8头猪
 百态   2023-07-31
女子体内爬出大量瓜子状活虫
 百态   2023-07-25
地球连续35年收到神秘规律性信号,网友:不要回答!
 探索   2023-07-21
全球镓价格本周大涨27%
 探索   2023-07-09
钱都流向了那些不缺钱的人,苦都留给了能吃苦的人
 探索   2023-07-02
倩女手游刀客魅者强控制(强混乱强眩晕强睡眠)和对应控制抗性的关系
 百态   2020-08-20
美国5月9日最新疫情:美国确诊人数突破131万
 百态   2020-05-09
荷兰政府宣布将集体辞职
 干货   2020-04-30
倩女幽魂手游师徒任务情义春秋猜成语答案逍遥观:鹏程万里
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案神机营:射石饮羽
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案昆仑山:拔刀相助
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案天工阁:鬼斧神工
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案丝路古道:单枪匹马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:与虎谋皮
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:李代桃僵
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:指鹿为马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:小鸟依人
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:千金买邻
 干货   2019-11-12
 
推荐阅读
 
 
 
>>返回首頁<<
 
靜靜地坐在廢墟上,四周的荒凉一望無際,忽然覺得,淒涼也很美
© 2005- 王朝網路 版權所有