ACM and STL
DNA Sorting
Time Limit:1000MS Memory Limit:10000K
Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
//By LingCh
//2005-3-19
Analysis
This is a sort problem. As stated, we may first calculate the inversions of each string, and then sort the strings use their inversion as the sort key.
Source
Memory:88K Time:0MS
Language:C++ Result:Accepted
· #include<vector>
· #include<algorithm>
· #include<iostream>
·
· using namespace std;
·
· int n,m;
·
· class Mystring
· {
· public:
· int length;
· int inv;
· char str[50];
·
· Mystring()
· :length(0)
· ,inv(0)
· {
· str[0]=0;
· }
·
· Mystring& operator = (const Mystring& s);
·
· friend istream& operator >>(istream &is,Mystring &istr);
· friend ostream& operator <<(ostream &os,Mystring &ostr);
· };
·
· istream& operator >>(istream &is,Mystring &istr)
· {
· int i,j;
· istr.length=n;
· for(i=0;i<istr.length;i++)
· is>>istr.str[i];
· istr.str[istr.length]=0;
·
//here calculate the inversion of this string
· istr.inv=0;
· for(i=0;i<istr.length-1;i++)
· {
· for(j=i+1;j<istr.length;j++)
· {
· if(istr.str[i]>istr.str[j])
· istr.inv++;
· }
· }
· return is;
· }
·
· Mystring& Mystring::operator = (const Mystring& sr)
· {
· if (&sr != this)
· {
· copy(&sr.str[0],&sr.str[length],this->str);
· inv=sr.inv;
· length=sr.length;
· }
· return *this;
· }
·
· ostream& operator <<(ostream &os,Mystring &ostr)
· {
· int i;
· for(i=0;i<ostr.length;i++)
· os<<ostr.str[i];
· return os;
· }
·
· //this predicate use the inversion of the string as the sort key
· bool MyPre(Mystring s1,Mystring s2)
· {
· if(s1.inv<s2.inv)
· return true;
· else
· return false;
· }
·
· int main()
· {
· int i;
· cin>>n>>m;
·
· vector<Mystring> ss;
· for(i=0;i<m;i++)
· {
· Mystring s;
· cin>>s;
· ss.push_back(s);
· }
·
· sort(ss.begin(),ss.end(),MyPre);
·
· for(i=0;i<m;i++)
· cout<<ss[i]<<endl;
·
· //system("pause");
· }