Problem:
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input:
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length
Output:
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file.
Sample Input:
1
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output:
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
Solution:
#include <iostream>
#include <string>
#include <map>
using namespace std;
// 声明:本代码仅供学习之用,请不要作为个人的成绩提交。
// email: bitrain@hotmail.com
int main( void ) {
int n;
cin >> n;
for ( int i = 0; i < n; ++i ) {
int len , row;
cin >> len >> row;
multimap< int , string > dnas;
for ( int j = 0; j < row; ++j ) {
string seq;
cin >> seq;
int ca = 0 , cc = 0 , cg = 0 , total = 0;
for ( int k = len - 1; k >= 0; --k ) {
switch ( seq[k] ) {
case 'T':
total += cg + cc + ca;
break;
case 'G':
total += ca + cc;
++cg;
break;
case 'C':
total += ca;
++cc;
break;
case 'A':
++ca;
break;
}
}
dnas.insert( pair< int , string >( total , seq ) );
}
if ( i != 0 ) cout << endl;
for ( map< int , string >::iterator p = dnas.begin( ); p != dnas.end(); ++p ) {
cout << p->second << endl;
}
}
return 0;
}