分享
 
 
 

ACM/ICPC Programming Exercise -- 1016 Parencodings

王朝other·作者佚名  2006-01-09
窄屏简体版  字體: |||超大  

URL: http://acm.zju.edu.cn/show_problem.php?pid=1016

Problem:

Let S = s1 s2 … s2n be a well-formed string of parentheses. S can be encoded in two different ways:

* By an integer sequence P = p1 p2 … pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

* By an integer sequence W = w1 w2 … wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))

P-sequence 4 5 6666

W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input:

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output:

The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input:

2

6

4 5 6 6 6 6

9

4 6 6 6 6 8 9 9 9

Sample Output:

1 1 1 4 5 6

1 1 2 4 5 1 1 3 9

My Solution: (C++, GCC)

You can solve this problem quickly if you have understood what the difference is between the P-sequence and W-sequence. Let's look at P-sequence first. Each integer in this sequence indicates the number of left parentheses before a right parenthese. In this way, subtracting Pi with Pi-1 and store the result into element p[i], the number of left parentheses between Pi and Pi-1can be calculated with ease.

SUBPi = Pi = Pi - Pi-1, specially P0 is same to the old one.

Here SUBPi indicates the number of left parentheses which are not coupled with the first i-1 right parentheses. Now let's have an iteration from SUBP0 to SUBPn, and you will find there are two situation we have to deal with. If SUBPi > 0, simply output Pi - SUBPi + 1. Otherwise search last left parenthese Li which has not been coupled with right parentheses, and count left parentheses between Li and Pi (include Li). What's more output the number you have just got.

#include <iostream>

// PS: The code is for study purpose only, never submit it as ones own.

// From: http://blog.csdn.net/mskia/

// email: ichobits@21cn.com

int main(void) {

int t;

std::cin >> t;

int p[20], subp[20];

for (int i = 0; i < t; ++i) {

int n;

std::cin >> n;

for (int j = 0; j < n; ++j) {

std::cin >> p[j];

}

for (int j = n - 1; j > 0; --j) {

subp[j] = p[j] - p[j - 1];

}

subp[0] = p[0];

for (int j = 0; j < n; ++j) {

p[j] = subp[j];

}

for (int j = 0; j < n; ++j) {

if (j > 0) {

std::cout << ' ';

}

if (subp[j] > 0) {

std::cout << p[j] - subp[j] + 1;

--subp[j];

} else {

int sum = 0;

for (int k = j; k >= 0; --k) {

if (subp[k] == 0) {

sum += p[k];

} else {

sum += p[k] - subp[k];

std::cout << sum + 1;

--subp[k];

break;

}

}

}

}

std::cout << std::endl;

}

return 0;

}

 
 
 
免责声明:本文为网络用户发布,其观点仅代表作者个人观点,与本站无关,本站仅提供信息存储服务。文中陈述内容未经本站证实,其真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
2023年上半年GDP全球前十五强
 百态   2023-10-24
美众议院议长启动对拜登的弹劾调查
 百态   2023-09-13
上海、济南、武汉等多地出现不明坠落物
 探索   2023-09-06
印度或要将国名改为“巴拉特”
 百态   2023-09-06
男子为女友送行,买票不登机被捕
 百态   2023-08-20
手机地震预警功能怎么开?
 干货   2023-08-06
女子4年卖2套房花700多万做美容:不但没变美脸,面部还出现变形
 百态   2023-08-04
住户一楼被水淹 还冲来8头猪
 百态   2023-07-31
女子体内爬出大量瓜子状活虫
 百态   2023-07-25
地球连续35年收到神秘规律性信号,网友:不要回答!
 探索   2023-07-21
全球镓价格本周大涨27%
 探索   2023-07-09
钱都流向了那些不缺钱的人,苦都留给了能吃苦的人
 探索   2023-07-02
倩女手游刀客魅者强控制(强混乱强眩晕强睡眠)和对应控制抗性的关系
 百态   2020-08-20
美国5月9日最新疫情:美国确诊人数突破131万
 百态   2020-05-09
荷兰政府宣布将集体辞职
 干货   2020-04-30
倩女幽魂手游师徒任务情义春秋猜成语答案逍遥观:鹏程万里
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案神机营:射石饮羽
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案昆仑山:拔刀相助
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案天工阁:鬼斧神工
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案丝路古道:单枪匹马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:与虎谋皮
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:李代桃僵
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案镇郊荒野:指鹿为马
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:小鸟依人
 干货   2019-11-12
倩女幽魂手游师徒任务情义春秋猜成语答案金陵:千金买邻
 干货   2019-11-12
 
推荐阅读
 
 
 
>>返回首頁<<
 
靜靜地坐在廢墟上,四周的荒凉一望無際,忽然覺得,淒涼也很美
© 2005- 王朝網路 版權所有