XXX#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service passWord-encryption
!
hostname XXXX
!
enable secret 5 $1$Y5WW$j4QQGpuNW.OKeGNfvKNeg. // enable secret 口令为Cisco
!
username user1 password 0 user1
username user2 password 0 user2
username user3 password 0 user3
username user4 password 0 user4 // 建立用户名和各自的口令
ip subnet-zero
!
async-bootp dns-server 10.14.128.29 // 为拨号用户提供DNS的地址
!
!
!
interface Loopback0 // 定义一个虚端口,用于拨号配置
ip address 10.14.144.254 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0
ip address 10.14.128.49 255.255.255.192 // 定义该访问服务器在Vlan1中的Interface的IP 地址
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Group-Async1 // 定义异步拨号端口组,interface 为Group-async1
ip unnumbered Loopback0 // 指明ip unnumbered 端口为上面设置的loopback 0
no ip directed-broadcast
encapsulation ppp
ip tcp header-compression passive
async mode dedicated //定义异步拨号为dedicated方式
peer default ip address pool address_pool-1 //为拨号用户指定地址池,地址池名为address_pool-1
no cdp enable
ppp authentication chap // ppp进行chap认证,结合前面定义的username和password
group-range 33 48 // Group-async1 对应line 33 - line 48
!
interface Group-Async2 // 定义异步拨号端口组,interface 为Group-async2
ip unnumbered Loopback0 // 指明ip unnumbered 端口为上面设置的loopback 0
no ip directed-broadcast
encapsulation ppp
ip tcp header-compression passive
async mode dedicated //定义异步拨号为dedicated方式
peer default ip address pool address_pool-1 //为拨号用户指定地址池,地址池名为address_pool-1
no cdp enable
ppp authentication chap // ppp进行chap认证,结合前面定义的username和password
group-range 65 80 // Group-async1 对应line 65 - line 80
!
ip local pool address_pool-1 10.14.144.1 10.14.144.32 // 定义地址池 address_pool-1的地址范围
ip classless
ip route 0.0.0.0 0.0.0.0 10.14.128.51 // 设置缺省路由,下一跳为当地中心路由器的Vlan1端口IP地址
no ip http server
!
snmp-server community public RO // 定义网管用 Read-Only权限 的community 为public
snmp-server community private RW // 定义网管用 Read&Write权限的community 为private
snmp-server host 10.14.128.25 private // 定义网管机的IP地址和权限
!
line con 0
exec-timeout 0 0
transport input none
line 33 48 // 定义 line 33 - 48
autoselect during-login
autoselect ppp
login local
modem InOut
modem autoconfigure discovery
transport input all
stopbits 1
flowcontrol hardware
line 65 80 // 定义 line 65 - 80
autoselect during-login
autoselect ppp
login local
modem InOut
modem autoconfigure discovery
transport input all
stopbits 1
flowcontrol hardware
line aux 0
line vty 0 4
password cisco // 定义telnet的口令为cisco
login
!
end